`Alexa, show the front door` not working on TV

Thank you for this feedback neighbors! Excellent work discussing as peers to try and find a solution. We will be sure to pass this feedback along to our teams here. :slight_smile:

Hi is there any progress/update to this issue? It’s both annoying and frustrating.

I would like to know this as well! It’s extremely frustrating!

Yup, me too…

Hi neighbors! Your feedback has been shared with the teams here, although this integration should be working as intended. I recommend checking out our help center article for information on how to ensure for an optimal experience with this integration. Although it sounds like everyone is using a compatible Alexa device, here is our Alexa and Ring device compatibility guide.

If you’ve checked the above, and the skill is not working on your tv, please check variables such as signal strength, not only for the Ring devices, but also for the Alexa and tv connection. Please also ensure the Ring app, and other related apps in use, are up to date.

Marley, this isn’t fixed at all. Ring has an opportunity to better the product with this thread.

I can duplicate this exact problem 100%. I also know of an inconvenient workaround.

Rather than being bothered by the inconvenience I just don’t use the feature anymore.

My Echo is configured with my Sony. I can ask Alexa to do most things TV-related (Alexa, what’s on Netflix?, or Alexa, turn down the volume, etc). Everything works, always, I think.

Also, “Alexa, show the front door.” works most every time - so long as I hold the TV’s Fire Stick remote control in my hands and press a button on it to wake up the Fire Stick.

If the Fire Stick’s remote control is not used for a period of time, something goes to sleep. Telling Alexa to “show the front door” results in the Ring app loading and briefly showing a “Waiting for Ring.com…” message on the TV.

I will NEVER get any further than that, unless I walk across the room, find the Fire Stick remote control and press a button on it. Any button, I think.

At that point, “Alexa, show the front door” works.

IMO, this issue is not fixed - unless you can confirm that using Ring on a Fire Stick device via an Echo does not work after periods of inactivity of the Fire Stick remote control. Otherwise, there’s a few dozen of us here that are trying to tell you something…

I started this thread after spending a fair amount of time with Ring support on the phone. We’ve taken settings to defaults and reconfigured everything involved - the end result of that support call was to say that your developers were aware of the issue.

Too much time for me to spend on the issue once I figured out a workaround. At that point it wasn’t worth it to me and I don’t use the feature. My cell phone is always by my side - I prefer to put the Fire Stick remote in a drawer out of site … your integration, if truly “working as intended” isn’t going to work for me. On my list of useful Ring features, “Alexa, show the front door” is not one of them.


^Exactly this.

Marley, this has nothing to do with the doorbell WiFi connection or any other standard troubleshooting step, this is a bug on all Amazon Fire 4k sticks. Namely, Ring simply will not work with an echo device unless you wake up the remote first.

It’s a bug identified by the community that needs fixing. But alas, I have also given up on this functionality as it hasn’t been working for so long. ?


Don’t understand why the need to “connect” echo to fire. Once skill is activated, the rest of the related fires will be able to do the skill too. My ring works with my ring app. Everything is on the same wireless mesh. I can hear the audio from the front door, but Alexa tells me that the camera cannot connect.

just now, as I was getting the exact verbage, it worked as expected, after having tried on three different 4K fires and this one now 5 times. The ring shows in the timeline that viewing occurred. But, not till just now did it work.

“random successs”? We’ll see.

Yep same problem with fire tv stick 4k and both of my ring cameras… Touch the remote and it works fine… This is an issue with ring and ring cameras … Because I can ask show me a wyze camera and works fine without touching to remote… So it’s ring’s integration

1 Like

Just tried this and have to say a big thank you. It works perfectly. Been struggling with this for days!!! No more. Wonderful

Everyone is having the same problemfor the last few months with their Firesticks. That was not a solution. Really “press a button on the remote to wake it”" Waiting for Ring.com…"appears on the screen as everyone keeps saying bu does not connect. The Firestick is AWAKE. Works on phones and other devices. Just not Firestick. Give us a real solution.

1 Like

It works for me and I can see all activity at my front door:smileyvery-happy:

Sigh, it still does not work if you don’t touch the Fire TV 4k remote first… Please people, before you post ‘it works’ please read the thread (and watch the video on page 2) as to what the actual problem is. Thanks.

Ring, why is this seemingly so difficult to fix? It works on the normal Fire TV, just not the 4k version so surely there must be a simple solution somewhere???

1 Like

Have already seen video and I understand perfectly well what you mean so why all the fuss about pressing a button!

  1. Because people want to automate this process when someone comes near their Ring Doorbell. At the moment this is impossible to do on the fire tv 4k, but possible on the cheaper non-4k version.

  2. Many people use universal remotes (I.e. Harmony remotes) to control their devices. A press on this remote does not fix this issue, so you cannot show Ring video feeds at all unless you use the supplied remote.

  3. It’s an annoying bug, that should be fixed.


With me it doesn’t even work by pressing the remote, so I’m out of luck completely!! They really should fix this ASAP! It’s been far too long now that this problem has been out there and Ring has done absolutely nothing about it, I really don’t understand why?! So many are complaining about it, not just here but also on the Amazon Forums and a lot of other Forums which only proves how many people are having this issue! It’s not only a few!

I had this issue and your solution fixed it for me. I followed what you said and everything now works fine.

1 Like

After many attempt it has worked to just ask to see the front door on my Firstick 4K by using the remote to ask. I would also like it if the developers would do like the Nest can and send a video to my Apple Watch when there is an activation.

I just wish mine would even work some time. I tell my Echo to show front. It switches my TV’s input to the 4K Firestick. I get the 3 dots “Waiting for Ring”, TV input switches to my my Apple 4K and that’s it. That’s the last time I see anything related to Ring. Now if I tell Echo to show front, it says OK and then switches to the Firestick, which thinks a bit and then switches to the Apple 4k. I can tell my Apple Fire tablets (with the Showmode stand) to show front and they do just fine. I can do it on my iphone, and on my Mac laptops/computers. And it works fine.

I spent half a day on on the phone with Apple. Got frustrated and hung up. They then sent me an email with “suggestions” included was to take every device off of my network. Reboot the modem, then the router. Which to me, even it it’s the answer, is “stoopid” beyond belief.

They should stop advertising that this works. It doesn’t. It did. And apparently, with looking at this thread, I am not the only one to have had this working and now it’s not. AMAZON/RING IT DOES NOT WORK!

It it works reliably for anyone, I would like to know their setup.

I’m having the same issue . I’ve tried everything without luck. Ring please fix!