`Alexa, show the front door` not working on TV

same issue

Same issue

Hey neighbors! We did have a concern when Alexa was a bit picky on what needed to be said to show the Live View for your device, despite having said the command before. The Alexa command, “Alexa, show me (Ring device name)” did not work, and neighbors would have to say “Alexa, show me (Ring device name) camera.” This has since been resolved, and both commands should now continue to work. Therefore, whatever your device is named, such as “Front Door,” you can say, “Alexa, show me the front door,” or “Alexa, show me the front door camera.” If you can, please give this a try, and let me know if this is working for you now, neighbors!

If you find that Alexa is unable to pull up the Live View, please follow the steps we outlined in our Community post here. You may also need to ensure you are not in a Mode within the Ring app that disables the Live View from loading. If you would like a full list of what you can ask Alexa to do with your Ring device, please let me know and I’m happy to gather that in a post in the Community here. If you continue to have concerns, video examples of this would be most helpful!

When attaching this video, you will need to compress the MP4 file into a ZIP file, as ZIP files can be attached to your reply and not MP4s. In addition, you can upload this video elsewhere, such as Youtube, and then share the link to the video in your reply.

Hi @Chelsea_Ring

The problem still remains. There is a video of the exact issue on page 2 of this thread:


As previously mentioned, the issue that Ring commands do not work via an echo device until the Fire TV remote has been pressed in some way, it seems as though this ‘wakes up’ the device and then the Ring ‘show me’ voice commands works every time. Again, exactly as per the video.

@shinedown78 Thanks for getting back to me and confirming that! I’ll have a member of one of my teams look more into this for us, but they requested the following:

  • Timestamp of when this video was taken in the day and the time zone that you’re in
  • Type of Fire TV you have
  • Build number of your Fire TV

Once we have this information we can look more into this for you!

Hi the video was taken on the 28th of March 2020, however, I could reproduce the exact same video today as the problem still exists with no change whatsoever, and not just for me, but for others on this thread too…

Here are the details:

It is an Amazon Fire TV 4k stick on the latest firmware: Fire OS (NS6271/2495). Also, my remote is on version 129.

Many thanks

@Chealse_Ring FYI, someone on this Amazon thread seems to suggest that this issue only effects the Firestick 4k devices, not the non-4k ones.


Confirming that this is the case for me. I only bought the camera yesterday and am already having several annoying issues, with Echo/Fire Stick viewing being just one of them.

4K FS shows “Waiting for Ring.com” then exits if we’ve been using our regular TV remote to control the television. Using the stock Fire remote to scroll through a page or two on the that Fire Stick forces the connection through. An older, non-4K Fire Stick in the bedroom connects after about 10 seconds, even if the remote hasn’t been used.

I have a 4k FireTV and having the same issue.

Having the same issue, FireTV 4K. I have to wake up with the remote before it will work. Also it not longer works unless I have the FireTV app open. It used to work no matter what input the TV was on. It would switch to the FireTV input and connect to the camera. Any idea what happened and will it be fixed?

I have the same exact problem. Has this not been solved yet? I’ve tried literally everything and nothing helps, the only thing which “temporarily” helps once or twice a day is if I turn on and off the box with USB and ADB debugging but then after a few minutes it stops working again. I really hope they find a solution soon, I can see by the date of this post that it’s a few months old now and nothing seems to have been done, why is that I wonder?!..

It looks like this problem is caused by the Fire Stick timing out and going to sleep. Your echo doesn’t seem to be able to wake up the Fire Stick.

To see if this is the cause of your problem, just press a button or two on your Fire Stick remote control. Then tell Alexa to show the front door.

Is that solution the official solution? Cause it doesn’t work on mine unfortunately. I’ve really tried everything I think and from what I can read around the Internet, the Amazon forums etc, there’s still a lot of people having issues with this.

1 Like

It’s what ‘officially’ works for me.

You would have to make sure the Fire Stick on your TV is connected to the Echo device. I forgot what that’s called.

Keep in mind, my Ring was working when I posted this question - I had set everything up and saw it all work. But after leaving things alone for some time it would no longer work when asked to “Show the front door”.

If you’ve never gotten it to work in the first place you may be dealing with a configuration issue on your Echo device. Open the Alexa app and connect your Fire Stick to the Echo.

I’d have to try this through my Fire cube. I don’t have it connected right now. But it seems like the app is being optimised and turning it off in the background. There may be a way to change this like an Android phone. Also, sometimes if you can lock an app open in the background like an Android phone. My echo shows all work quick and fine. They even come right on with a doorbell press too. But I haven’t tried this with my Fire cube yet. If I get a chance I’ll try and see if I can get it to work. Hope this helps.

1 Like

I’m having this same problem for a while now. Even upgraded to the doorbell 2 because support told me it would fix the issue. I can be watching my fire stick 4K and it will not work until I press a button on my original remote, then it will work with my echo. It started doing this after all the ring stuff got hacked and hasn’t worked since.

Having to use the Fire remote before an echo shows the Ring feed is the problem being discussed here, it certainly isn’t the ‘solution’ as it has been labelled in this thread!

1 Like

It really is a puzzle. I never had the problem before, it used to show the live feed on my fire tv whenever I asked to show the front door and then suddenly it now refuses to do so. Maybe it’s an update on the firestick which causes it…

btw, my setup is this: Ring peephole doorview cam (Think it’s called) and Firestick tv 2. Gen. And also I use it with an echo Dot 2. I have several other echo shows but I connected the dot directly through Bluetooth, doesn’t matter though cause it’s the same no matter which echo I use it with, the ring Doorbell will show live feed on the echo shows but not on the fire tv stick.

Purchased a new ring doorbell 2nd generation set it all up with no issues everything worked perfect with Alexa except showing the live feed on fire stick 4K on my tv…

I had all the identical issues as everyone else posted here it would start with the little dots then just going back to fire tv home screen…I rebooted relinked re everything with no joy.


THEN using the original fire stick 4K remote control I pressed the microphone button and gave the show ring camera commands while on the fire stick home screen and by heck it worked and showed the doorbell live stream on my telly that I never managed to do any other way…

then I tried using Amazon echo devices in the normal way giving the Alexa show ring doorbell and that also worked!!! it switch source to fire stick and showed ring doorbell feed live and with sound etc…wow.

all working as it should now showing every time…

Let us know if it works for you…


^waking the remote is the issue here and only a temp solution at that, it will soon go back.

Ring/Amazon need to fix their integration so you don’t have to use the remote first to get an echo device to show the Ring feed. This bug only impacts the 4k Fire Stick, not the non-4k variant. So it really shouldn’t be that hard to identify but it has been like this for more at least 12 months now…

1 Like