`Alexa, show the front door` not working on TV

^Exactly this.

Marley, this has nothing to do with the doorbell WiFi connection or any other standard troubleshooting step, this is a bug on all Amazon Fire 4k sticks. Namely, Ring simply will not work with an echo device unless you wake up the remote first.

It’s a bug identified by the community that needs fixing. But alas, I have also given up on this functionality as it hasn’t been working for so long. ?

2 Likes

Don’t understand why the need to “connect” echo to fire. Once skill is activated, the rest of the related fires will be able to do the skill too. My ring works with my ring app. Everything is on the same wireless mesh. I can hear the audio from the front door, but Alexa tells me that the camera cannot connect.

just now, as I was getting the exact verbage, it worked as expected, after having tried on three different 4K fires and this one now 5 times. The ring shows in the timeline that viewing occurred. But, not till just now did it work.

“random successs”? We’ll see.

Yep same problem with fire tv stick 4k and both of my ring cameras… Touch the remote and it works fine… This is an issue with ring and ring cameras … Because I can ask show me a wyze camera and works fine without touching to remote… So it’s ring’s integration

1 Like

Just tried this and have to say a big thank you. It works perfectly. Been struggling with this for days!!! No more. Wonderful

Everyone is having the same problemfor the last few months with their Firesticks. That was not a solution. Really “press a button on the remote to wake it”" Waiting for Ring.com…"appears on the screen as everyone keeps saying bu does not connect. The Firestick is AWAKE. Works on phones and other devices. Just not Firestick. Give us a real solution.

1 Like

It works for me and I can see all activity at my front door:smileyvery-happy:

Sigh, it still does not work if you don’t touch the Fire TV 4k remote first… Please people, before you post ‘it works’ please read the thread (and watch the video on page 2) as to what the actual problem is. Thanks.

Ring, why is this seemingly so difficult to fix? It works on the normal Fire TV, just not the 4k version so surely there must be a simple solution somewhere???

1 Like

Have already seen video and I understand perfectly well what you mean so why all the fuss about pressing a button!

  1. Because people want to automate this process when someone comes near their Ring Doorbell. At the moment this is impossible to do on the fire tv 4k, but possible on the cheaper non-4k version.

  2. Many people use universal remotes (I.e. Harmony remotes) to control their devices. A press on this remote does not fix this issue, so you cannot show Ring video feeds at all unless you use the supplied remote.

  3. It’s an annoying bug, that should be fixed.

2 Likes

With me it doesn’t even work by pressing the remote, so I’m out of luck completely!! They really should fix this ASAP! It’s been far too long now that this problem has been out there and Ring has done absolutely nothing about it, I really don’t understand why?! So many are complaining about it, not just here but also on the Amazon Forums and a lot of other Forums which only proves how many people are having this issue! It’s not only a few!

I had this issue and your solution fixed it for me. I followed what you said and everything now works fine.

1 Like

After many attempt it has worked to just ask to see the front door on my Firstick 4K by using the remote to ask. I would also like it if the developers would do like the Nest can and send a video to my Apple Watch when there is an activation.

I just wish mine would even work some time. I tell my Echo to show front. It switches my TV’s input to the 4K Firestick. I get the 3 dots “Waiting for Ring”, TV input switches to my my Apple 4K and that’s it. That’s the last time I see anything related to Ring. Now if I tell Echo to show front, it says OK and then switches to the Firestick, which thinks a bit and then switches to the Apple 4k. I can tell my Apple Fire tablets (with the Showmode stand) to show front and they do just fine. I can do it on my iphone, and on my Mac laptops/computers. And it works fine.

I spent half a day on on the phone with Apple. Got frustrated and hung up. They then sent me an email with “suggestions” included was to take every device off of my network. Reboot the modem, then the router. Which to me, even it it’s the answer, is “stoopid” beyond belief.

They should stop advertising that this works. It doesn’t. It did. And apparently, with looking at this thread, I am not the only one to have had this working and now it’s not. AMAZON/RING IT DOES NOT WORK!

It it works reliably for anyone, I would like to know their setup.

I’m having the same issue . I’ve tried everything without luck. Ring please fix!

This is primarily directed at anyone from Amazon and/or Ring. Assuming a real fix is still in what seems like a very long pipeline, IMHO having to press the mic button to request the feed from a Ring camera is not a fix it is a workaround. I have several Blink cameras too and they never fail to show on my TV no matter what mode (awake or asleep) the Fire TV happens to be in at the time. This suggests it is a Ring/Firestick integration issue. Has anyone found a real fix?

1 Like

Still no fix for this issue? The “wake the remote” trick works for me, but that’s NOT a fix, guys. The integration between Ring products and Alexa/Amazon Firestick is unacceptable. This applies to any type of Ring live video feed. The contact/motion sensors all work fine when polled, as does control over the base station. But when I request live feed from my front door or security cameras, I get the now infamous “Waiting for Ring…” screen, then nothing - back to whatever the Firestick was displaying prior to my request.

Yes I got exactly the same. Ring video doorbell 3, 4K firestick and Samsung 65".
video bell works fine in app, but not on tv. 2 Blink cameras work via Alexa/firestick no problems.

the “solution” is indeed a workaround and not a fix!
plenty of bugs in Ring products, including the solar panel, need fixing!!

1 Like

Hi,

I know it’s off topic a bit but I can confirm that there is something really messed up with the Ring / Amazon integration.

I have a Ring Pro device and an Amazon Echo Show 5. Never worked no matter what I try, I see the Ring with those anoying dots and it goes back to the home screen.

So not only with the FireTv 4K

1 Like

This is happening to me on echo show. I don’t have a firetv on this tv so that isn’t a possible solution.

It seems that after just about a year ring/amazon don’t care that we can no longer use the devices since they already have are money. After a few months someone from ring will reply here saying they will pass this on then ask us to check things they no are not the issue like connectivity and passwords or what ever. We as a community have given very detailed information on the issue as well as an annoying work around that most of us no longer use the show front door command. It’s crazy because amazon was well known for customer service and ring use to be great with customer service as well but after the merger things are going down hill.