`Alexa, show the front door` not working on TV

I have a Ring Doorbell Pro and it seems to be working correctly everyplace but showing on my Sony XBR75. I can tell Alexa to show the front door on an Echo Show 5. Works as expected. Also have no problems with the Ring App on my iPhone.

When I tell my Echo Dot to show the front door, Alexa responds with “Ok” and I see my TV go to a page that says “Waiting for Ring.Com…”. After a few seconds the screen disappears and my TV goes back to what it was showing before I issued the command.

The TV has is using an Amazon Fire Stick 4k. TV is connected via WiFi.

Does anyone hve any idea on what could cause this and/or how to troubleshoot it?


I have this same problem. I started happening in the last couple months. Prior to that it worked great for me every day. I’ve tried disabling the skill and re-enabling it. No luck. I have 15 ring cameras and multiple echo/fire-tv combos. I get the same result on all of my tv sets.

I discovered that another was interferring. I can’t tell you why, just that when I have the HDHomeRun app installed I cannot get Alexa to show a Ring camera. When I uninstall the HDHomeRun app the Ring shows fine.

You may need to try uninstalling your apps one-by-one until you find the culprit.

Has anyone found a solution to this?

It seems odd to me that another app was the culprit for me. The HDHomeRun app doesn’t even have to be running - just installed. I can duplicate the issue on my setup 100% so I’m confident there’s a conflict between the Ring app and the HDHomeRun app.

For the time being I am installing and uninstalling the HDHomeRun app as-needed.

It’s a pain to uninstall apps, but I suspect you’ll find the culprit on your setup by uninstalling each app one-by-one. Try to show your Ring camera and if it doesn’t work just reinstall the app and move on to the next one.

I found the same on all fire sticks in the household on initial setup (They showed waiting for ring.com and had a short burst of mic feed before hanging) but after unplugging each firestick for 30sec. They now work fine. (One of them took 2 attempts) I don’t know if simply restarting the firestick would have the same effect or if you need a complete power down of each. Hope this helps!

1 Like

I managed to get this working as per suggestion below. Had to keep the firetv remote running and synced as I use harmony remote. But once I had the old fire remote working and tested with the mic everything works. Problems is if I remove the batteries and dnt use, then from door keeps saying waiting on ring. Com and quits…

1 Like

I have the exact same issue, ring app starts for a second then goes back to the home screen. I used the remote technique, it seemingly worked, but it always goes back to the problem in the end

Same issue being discussed on the Amazon Forums here: https://www.amazonforum.com/s/feed/0D54P00007JLVjz

1 Like

Hi, can I just say that unplugging my firestick from power supply (TV USB port for me) worked. I’ve had the same error for ages where when I asked Alexa to show front door, my TV gets stuck on loading Ring.com page.

Update: stuck again. It worked only once.

My setup: LGTV, ring pro, Amazon firestick, echo dot

1 Like

I also have a Harmony remote and cannot get Ring to show via an echo dot command until I ‘wake’ the Fire TV remote with any press, then it works without fail.

It is so irritating that you need to do this, particulary when I have an automation that shows the camera feed on my TV when my doorbell detects motion (a Sonos speaker ask my dot to ‘show the front door’), it works flawlessly, but the camera feed never shows unless I’ve ‘woken up’ the Fire TV remote first!

Here’s a video of the situation: https://youtu.be/X6FkeYFRQJU

1 Like

@shinedown78 Wow! Thank you so much for the video. We will send this and the Amazon forum to our team for review. Appreciate these detailed insights!! I’ll be in touch with more information as soon as possible. Thank you!

1 Like

No problems Jennifer, would be great to get a fix! ???
It’s like the Fire TV needs to ‘wake up’ using the remote before the echo dot commands work. It’s very strange, but it then works every time without fail!

Just to add, my Fire TV is on firmware: (NS6271/2495) - latest version. Also, my remote (version 129) shows ‘battery offline’ in the settings until it is pressesd, where it then shows ‘OK’ - I’ve got a feeling that this remote sleeping thing could be something to do with it…

Hi, any update on this?

I’m having this problem too. Any fixes yet?

Same issue for me. Simple repro. No echo dots involved. I can’t view my Ring doorbell from any of my Fire TV Sticks. I have 4 around the house. When I send the voice command it just spins on the Waiting for Ring.com screen. I also have an Echo Show and it works on that.

What info is needed for Ring/Amazon to troubleshoot this and resolve?

Hi, would be great to hear back from Ring as to where we are with this, many thanks.

Exact same issue here, firstick 4k with LG TV, works fine once remote is woken (if already on amazon input) can’t work out how to get it to switch to firstick to show the image if I’m watching another input source though, but that’s probably a question for another thread.

what I want to do is a described above ie

watching Sky

Doorbell rings or motion detected

tv switches to firstick input and shows display from doorbell or garden camera

once I have seen it and dealt with it, or by saying stop tv returns to original input

but need to get the first issue fixed before I can try and work out above I suppose

fix it please