Alexa, show me event!

Why won’t the Alexa skill show my most recent video event as advertised?

I say: Alexa, show the most recent event from [Ring Device Name].

She answers: Here are some of your photos (AMAZON Photos)

Extra Details:
I live in Canada
I have a ring Doorbell Pro
I Have a Ring Plan for this doorbell
I’ve tried on my phone and on my Echo Show

Hey @Kmcm. Do you have a skill for Amazon Photos in the Alexa app that you could disable, and then try with asking Alexa to pull up the recent event?

In addition, I noticed from that they state you need to ask Alexa, “Alexa, show me the last activity from the front door,” and our website in our Help Center Article, we state you need to say, “Alexa, show me the last activity from [Ring Device Name].” It’s possible the missing link is the “the,” although it seems a little silly. If you don’t mind giving it a try, throw the “the” in front of asking Alexa for that last event, and let me know if this helps!

You may need to also give your Doorbell a more unique name, and then try asking Alexa to show you the event with a more unique name. Let me know how this goes, I’m very curious to see if we can nail this! :slight_smile:

Hi, @Chelsea_Ring, thanks for the reply.

I’ve done some testing. Using both phrases warrants the same result. Alexa will try to open my amazon photos. She will state “Here are some of your photos”

Interestingly, she will only do this for my ring doorbell. If I say “Alexa, show me the last activity from Echo Show” She’ll say “Sorry, I don’t know that”. If I say “Alexa, show me the last activity from [Fire TV]” she’ll again say “Sorry, I don’t know that”

I then tried asking “Alexa, show my the last activity from [Great Gate]” and she replied “Sorry, I don’t know that” I then RENAMED my “Front Door” to “Great Gate” and I asked again: “Alexa, show me the last activity from [Great Gate]” and she answered “Here are some of your photos”

From this, I gather that the phrase is working but Alexa is performing the wrong task! Very weird. I have no other skill relating to photos, amazon photos is built into Alexa

@Kmcm Awesome job with that testing! It seems like Alexa just simply does not understand or know this command to take it to the right route. I reached out to a colleague that also has an Alexa device, and they were able to pull up their recent event with that command, so it may be something specifically with your device not taking the right path with that command.

Have you tried rebooting your Alexa device or reaching out to their support team? I would say, before reaching out to their support team, try disabling the Ring skill and then re-enabling it to see if this helps. Although, if it’s to no avail, let me know what their support says! :slight_smile:

Hi I have the same issue, was a solution found?

1 Like

Yep - same problem - any further with solution? thx