Alexa Routine not firing with Stick Up Cam Motion

I’ve recently added a Stick Up Cam to my Ring Family of camera to replace a Wyze cam. I did this because I was interested in using it with Alexa Routines and my smart lighting.

I’ve set up the camera and its working great, Alexa notified me that it had found the camera and added it to my available devices.

I’ve gone into routines and set up “when stick up cam sees motion, turn on the light” … I also added “send me a notification” just to make sure it was working. But the stick up cam doesn’t appear to be communicating with Alexa that motion has happened.

I use a similar routine for the doorbell which works perfectly … someone presses the bell and the hallway light comes on.

Have I dont something wrong? I’ve tried different variations and I can’t get it to work at all. Any advice would be appreciated!

I would love to know if this is simply a known bug within the system and is being looked into or if perhaps it’s something that isn’t quite set up correctly.

For anyone else who experiences this problem I have found the answer. Make sure you give all of your devices and groups unique names.

The bulb in the room and the camera were both called the same thing. I wasn’t aware but this was what was causing the issue. Changed the name of the camera and this has now solved the problem!


Thanks for sharing this information with the Community! Amazing work finding this solution yourself. Many will certainly benefit from this thread as Alexa and Ring integrations continue to grow. We hope you continue to enjoy your ‘Ring of Security’!

Not working for me! I have 2 stickup cameras and a ring video doorbell 2. Cameras work great, motion is detected and phone shows the motion. Will not trigger a routine. I’ve uninstalled/reinstalled Alexa app. Ive disabled/reenabled the ring skill etc.Will not trigger routine nothin hapens on all 3 cameras. HELP!!!

1 Like

I’m having the same problem. My Ring cameras (floodlight; stickup, and indoor) detect motion, but do not forward the alert to Alexa. Or if they do forward Alexa isn’t listening…

Did you find a solution as I’m stuck with the same situation


I never tried this before. But I just setup my new and old model to try this out. So it can be done. Now to see if it works for me. I’ll let you.

To my knowledge of what research I have found and trying the routine all day, this available in the US but not the UK as of yet? But let us know know as I may be wrong

Ah, I’m in the US. Could be the difference. But I’ll let you know. I’d wish they’d let us know where people are from so we could check that as well. Different options for different regions makes it harder to help others…

I’m in the US as well

Stick up camera motion records in ring but will NOT trigger Alexa routine. Maybe related neither will sunrise or sunset times. Is there a master, ‘ignore all events’ in Alexa?