Alexa Guard issue

I am trying to use Alexa Guard on my Echo Dot with my Ring Alarm System. Whenever I go into the Alexa app, however, I keep getting a red alert that says “Ring security system is unreachable.”

My Ring Alarm Base Station is connected to my modem via ethernet cable. And my Echo Dot connects via WiFi. Could this be causing the problem? Do I need my alarm to be connected by WiFi to fully use Alexa Guard?

Thanks in advance!

Hi @rdkrauss. Having your Ring Alarm Base Station hooked up to Ethernet or wifi shouldn’t affect the functionally of Alexa Guard, as long as your Base Station has a reliable and steady connection. I recommend to remove the Alexa app from your phone, reboot your phone (turn it off/on) and then reinstall your Alexa app. Once you do that, attempt to set up Alexa Guard again. If this concern persists, please attach a screenshot of this error so we can look at it further for you!

I tried the steps you suggested bu the problem remains.

Here is what I am seeing:

My alarm and base station remain online at all times, connected via ethernet. I have no issues there. So not sure what the issue is with Alexa Guard.

Glad I saw this. I justed checked mine and it wasn’t on either. Same error. Also all my lights and cameras were off of Alexa.
I uninstalled the skill in the Alexa app. Restarted my phone and the added the Ring skill back. Signed on and everything now is online again. I’m thinking it was the skill that was updated 3 days ago that caused it. Hope this works for you.


This worked for me. Thanks so much!!

Glad it worked out for you too!