Alexa app on iPhone says I do not have permission to view Ring doorbell

When I select the doorbell in the Alexa app on my iPhone it says “You don’t have permission to view Ring cameras on this device. The owner of the camera can update permissions from Control Center in the Ring app.”

  1. I am the owner.
  2. The accounts are linked or else I would not be able to select the doorbell in Alexa app.
  3. I can see the doorbell on Echo show.
  4. I can find nowhere in the Ring app Control center to authorize my own phone to access the camera via Alexa.
  5. I have disabled the skill in Alexa, deleted the device, reenabled the skill and re-added the device.

No joy.

What am I doing wrong?

Hi @MrFixitOK. The Owner of the device is the person that set the Doorbell up under their Ring account. To confirm, this is the same Ring account that is linked with the Amazon account, correct? I’d also recommend checking that both your Ring app and your Alexa app are fully updated to the latest versions available.

I have this exact same problem. And doorbell notifications have stopped working. I am the owner and I have authorized all devices. In fact, I disabled them re enabled the ring app in Alexa and reconnected and re authorized everything and I still get the same error. I have also restarted my doorbell and restarted my echo devices.

Hi @Caitlyn_Ring I still have this issue. I have disabled and re-enabled the Ring app in Alexa. Both Ring and Alexa apps are completely updated. I am the owner of both accounts so permissions should not be a problem. I also completely factory reset and reinstalled my front door camera.

In the past I was able to view Ring cameras on my Alexa app, get notified on my Fire TV when someone was at my front door, and hear a doorbell chime on my Alexa devices when someone pressed the doorbell. So it did all work fine at one point. Now none of it works and I get the same aforementioned permissions error as shown in the screenshot posted.

Your help would be appreciated.

Hi @Dano23. You’ve already completed all the troubleshooting steps I would have recommended for this issue. Since it persists, I’d suggest reaching out to our support team to take a closer look. You can give our support team a call at one of the numbers available here. You can also get in touch with our support team on Facebook @Ring by sending a private message.

Had the same problem. I discovered that it was set on my wife’s profile. Just had to change it back to mine and it worked.

1 Like