Add "Don't Record" button to current live view session to prevent timeouts

Does the timeout have something to do with the amount of recording space?

How about offering a switch in live view to turn off recording for the current live view session?

(X) don’t record button. And then allow it to stay active until the live view session is closed.