A19 smart lightbulb not connecting

I am trying to connect my smart lightbulb a19 to my app, and I keep getting the same error. I even tried doing a factory reset using my iPad to set it up, but still no luck.

After I scan the barcode, the app detects the lightbulb. After I name the lightbulb and proceeded to the “Set Up a Device” page, my echo recognizes the new light. However, after about 30 seconds or so, it says that there is a connection issue saying “Hmm, something went wrong. Sorry about that. Please try again”

I am using echo gen 4 as a bridge.


This is the error page I get.

Hi @noahsjung. If your setup for your A19 Smart LED Bulb is failing, try these additional steps:

  • Be sure the bulb will be installed in a fixture that does not have an internal dimmer, motion or light sensors, or a built-in timer.

  • Try doing the setup with out scanning.

  • Power cycle the bulb by shutting power off to it via your switch for 10 seconds.

  • Factory reset the bulb by using the light switch, power cycle bulb 6 times on and off in (Off 2 seconds, on 2 seconds). On the sixth time leave it on and the bulb should pulse slightly to indicate reset.

  • If possible temporarily bring your Echo 4th Gen closer to the bulb or vise vera.

If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assitance. If you are outside of the US, please visit here to see how to contact support.