404: The page you're looking for doesn't exist.

Alot of “404: The page you’re looking for doesn’t exist.” errors on your website today.


been having same issues with the website for a few days now.

I have the same issue. I’m trying to make an order and I get a 404 when I try to access my cart or to checkout. (https://ring.com/shop/go?url=/cart)

Hey neighbors! Do you have a screenshot of this error and a detailed flow of what you are doing on the website that then prompts this error? Please ensure you are on a web browser that does not have any VPNs turned on for the network, as the website conflicts with VPNs and will not work. In addition, you can try clearing your cache and cookies to see if this helps! In the event that this may persist, a screen recording of what is preformed to get this error may help us figure out what could be causing it! :slight_smile:

It’s now working for me, even though I did nothing special (did not clear cache, did not switch to a different network, etc)

Earlier today, I tried the following procedure, both on my PC and on my iPhone. On my iPhone, this was the first time I was accessing shop.ring.com

The procedure I used to get the error was:

  1. Go to shop.ring.com

  2. Add some items to my cart

  3. Click on the Cart icon (top right of the screen), then click either View Cart or Checkout.

Both options generated a 404 error: “404: The page you’re looking for doesn’t exist.”

The following URL should still show the error: https://shop.ring.com/TestToReproduceA404ErrorUsingAUrlKnownToBeInvalid

Earlier today, I had the same error on https://ring.com/shop/go?url=/cart

1 Like

Signed onto ring.com

clicked on products
recieved error.

happens all the time on different pages on the site

Thank you for confirming your situation @ckarras, and I’m glad it’s working now! It’s possible our website may have been down during this time. In addition, it makes sense that the URL for test that you provided does not turn up anything from Ring.com, as it was a made up URL, but I see the error message from that link, so much appreciated. I’m unsure why your cart would give this error, but it could be maybe our systems were down, which would explain it!

Hey @DaveR, I’m not too sure why you would still be having this error, as the accessories page should work for you as it has on my Google Chrome browser. Are you using an outdatedbrowser version, or possibly any VPNs when browsing? VPNs being turned on will not allow you to connect to Ring.com, so you will need to ensure these are off. In addition, if you are outside of the US, I recommend using the country selector at the bottom right of Ring.com to go to your country’s page to avoid errors. Let me know!

1 Like

I am still getting the error. My browser is updated, I cleared my cookies, and I do not have a VPN.

I sign in, go to my account, click my plans, and then click shop plans.

My ring plan has now expired because I have been getting this error for several days.

@L111 Could you try reaching out to our support team to see if they can help with this concern? Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. They can help sign you up for a new plan, but let me know if they’re able to isolate the concern with the website doing this for you.

Changed my location on the website from Canada to USA and site works without issue

1 Like