2 factor USA mobile number

When trying to enable two factor, entering my cellphone number is stating enter a valid mobile number. Here is what I entered and it auto formats to

+1nnnnnnnnnn. To +1 nnn-nnn-nnnn.
It won’t recognize as a valid number, tried putting a space after 1 and after + and replacing with 001. None of them worked. Any suggestions for right format for a US phone number?

Should be +1 xxx-xxx-xxxx. I just turned mine off and back on to check. There is a single space between the +1 and phone number

Thankyou. For some reason, 2 factor enablement via Ring app was not working. I deleted the app and reinstalled on my Android device. Enabled the 2FA on ring.com site. it seems to work very well for any site related to ring.com. When I launch the Ring app, enter my credentials and enter 2FA verification code, it comes back with a message something went wrong even though the all the information is correct. Not sure why it is failing to login on Android device only.

Looks like there may have been issue with the Android app. There was an update today and it fixed. It is working without any issues.

I am very suspect of ring’s 2-step verification. Ring is already painfully slow to open every time I get a notification, rendering its usefuleness to be very minimal, already, as it is! Suffice it to say I’m a very unsatisfied customer. So if I sign into two-step will that delay it even further, making it totally useless to see who ever is at my front door, making me go to email or text and then get a code and sign in again before I see who’s there??? Please Ring people I know you read all these things let us know about this. There’s gotta be a better way. Lots of probs with your product, I’d like to see it work better.

You only need to do it once when you sign into your app. It takes me 2 seconds. I get a text quickly that on my phone tap to copy the number and paste it in. And I’m done. Unless you remove the app you don’t need to do it again.

1 Like