2.4GHz Chime that came with a Video Doorbell 2

2.4GHz Chime that came with a Video Doorbell 2 worked with my 2.4Ghz / 5GHz Wifi router on the 2.4Ghz band, the only band that chime and video doorbell can use. I had to reset the router because the router stopped responding to traffic. The meant the wifi router password changed back to the default printed on the router. The video doorbell 2 was able to be reconnected easily the 1st attempt using the new password. The chime I have made at least 20 attempts all with the new password, resets, deleting from the Ring app and adding it back again, leaving it unplugged for a couple of hours and trying again, moving the chime to literally 3’ of where the wifi router is and all of that has been to no avail. These attempt succeed to connecting to the “Ring Setup 3” network but fail when the connection is tried to my Wifi router’s network. The router uses the standard security that modern wifi routers use from the wireless encryption. No other devices I own have trouble connecting to it.

What is wrong with that chime? It’s looking like the firmware or the Ring remote server site are borked and preventing my chime from being added back in service.

I should add, I’ve already did a reset twice of the Chime device by holding the reset button 25 - 30 seconds to reset the chime device and deleted it in the Ring app as mentioned by Ring support in another thread. Of course, now that the chime device won’t connect to my WiFi network the chime fails to get added back into my Ring app.

Thanks for your help.

I solved my problem:

I have a Belkin WiFi Router. I reset it but I did not connect to the configuration address to configure the router but instead used the password printed on the bottom of the router.

It seemed OK doing this as a 2016 iPhone SE on both 2.4GHz/5GHz, Samsung Galaxy A10e on both 2.4GHz/5GHz, and a Windows 10 Desktop on both 2.4GHz/5GHz all connected to it fine and the internet worked.

However as I said the Chime would not work.

I also had to reconfigure a ROKU MDL Stick on both 2.4GHz/5GHz and even though I could connect for both bands neither internet connection worked.

Therefore I connected to the Belkin Router on and followed the directions the Belkin Router asked for my to do.

After that, my ROKU MDL Stick started working again on both bands the internet and I was again able to configure my Ring Chime on the 2.4GHz band. The Ring Chime I have has no 5GHz band. It now works again.

So, a somewhat deceptive problem in that some devices worked using that Belkin WiFi router and some did not using that Belkin WiFi router until I actually connected to the Belkin Router and configured it according the the instructions it gave me. I didn’t change any configuration data it had though but simply manually typed in the 2 names of the WiFi networks it was broadcasting and also the default random password it supplied printer on the router.

So if you have similar problems with your brand WiFi router, give a similar configuration procedure for your WiFi router a try.


Ring Community Forum Software is falsely flagging my posts even though this solution I discovered and tested is the solution that works.

1 Like