1st ring chime

My chime 1st gen is completely dead it worked fine, I unplugged it for a while while we moved home but when I plugged it in again … nothing, I’ve tried everything I can think of but it’s still dead/ frozen . Any ideas ?

Hi @DADXBLX. Have you tried resetting the Chime? You can do this buy holding the reset button for 20 seconds, then release. After one minute, you can reconnect it to wifi. Even if the light on the Chime doesn’t appear right away, go through the process of reconnecting as if it is lit up correctly. If successful, the Chime will do a quick update and the light will restore. I hope this helps!

Yep tried that but still no life in it, I’ve been trying to contact ring support but the line keeps getting cut off after I select English, think I may just have to go buy another chime

Hi @DADXBLX, happy to chime in here. I’d definitely recommend contacting our support team at one of the numbers available here. They can take a closer look and determine if your Chime needs to be replaced under its warranty. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.