Still weak Wi-Fi signal after installing chime Pro

It took a long time to get this to actually hook up this chime Pro.

Family have a twerking and it is hooked up and says that it’s working but I still have a very weak signal and motion delays are still from 5 to 20 seconds after they happen.

Any ideas?

Hey @Rella ! The first best step would be to ensure the Camera/ Doorbell device is connecting to the Chime Pro as an extender. Visit your Camera/ Doorbell device in the Ring app, then select it’s “Device Health”, and make sure the network section of this page shows “Chime Pro” as what is connected.

Something we always recommend to improve alerts is to uninstall and reinstall the app to ensure it is up to date. Also, please test motion alerts while your mobile device is connected to wifi only, and again on data only, to see if one connection is quicker than the other.

Let us know how it goes! :slight_smile:

I have been struggling with this issue for just over a year (when I installed a Ring Doorbell 2 at our Nashville home. The front door is 25 paces off the Netgear R8000 router now running off a 300 Gps Fiber line. I STILL get weak signal, slow connections (the fiber is synchronis! Meaning upload/download speeds are the same. Fiber means it is NOT shared. I’ve tested the speeds including in front of the doorbell and even with kids, streaming, etc., we’re talking 100 speeds! at the bell).

I bought a chime to allow notices upstairs (which is where the chime is located). Again, the doorbell and main hub router are VERY close (less than 10. paces and NO concrete or unusual structural issues in between).

At this point this isn’t really a usefull device (with over a year’s testing). The false positiv e notices are another issue. For now, I just want to answer the bell. Thanks in advance for any help and assistance with this matter.

I’ve tried all what ring has advised in doing, but still getting weak connection from both doorbell & chime pro?

Just feels that i have paid out money for no reason because chime pro is total rubbish. It does’nt expand your wifi & also very hard to connect it, been at it for approx 5hrs now with achieving no further than asmatic ant with a heavy twig.

Hey @mikeybabe. If you find you are getting a weak signal still even with a Chime Pro installed, can you please reach out to our support team so they can take a more in-depth look at the connections for your devices? Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to come back and let us know how this goes! :slight_smile:

I am so fed up as well I bought the Blink system first it worked fine for like 2 months and then it just stopped working so then I returned it and got the Ring doorbell and 2 stick up cameras they were ok but STILL weak WIFI!!

So I just 2 days ago bought the wifi extender the chime pro and it was strong after I had to set it up and my doorbell is hardwired but it required me to hit that orange button behing it, I had to halfway unhook it to do this then it was fine for a few days and now it is back to poor wifi!!! I am so fed up!!! If you hear of a fix can you let me know I feel like all the wasted money is SO ridiculous!!! I am in Wisconsin. :frowning:

Hi @Pammyzz. It seems like you may not have a strong enough wifi signal and strength to support the Ring devices. What all Ring devices do you have connected to your wifi, and could you go to Ring.com/speed and let me know what your upload/download speeds are?

Hi Chelsea my test states this:

Download: 37.20 Mbps

Upload: 12.60 Mbps

Ping: 58 ms

I hope you can help because I am going BROKE with the Ring System :frowning: :frowning:

@Pammyzz No worries and thank you for doing that test! You have just the Doorbell and 2 Stick Up Cams, correct? If so, you should have the appropriate speeds to have the devices functioning, as they generally only need 1-2 Mpbs of both speeds. At this point, since you have the right speeds but still get the weak wifi signal even with a Chime Pro, please reach out to our support team to have them take a more in-depth look into this.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

Chelsea Thank you I will call as soon as I am able to do so.

                                 Pammyzz
1 Like

My signal is week and I have 75.65 download speed and 7.60 upload speeds. I have the chime pro and it sporadically goes from good to weak signal to offline occassionally.

How do I improve this?

I am having a similar issue. My house is under 1000sqft and I have connection issues with the cameras just 10 to 15 feet from router and chime pro. I also have the extender that came with the alarm system. When contacting Ring support, I was told I need a 2nd chime pro. How can that be? I have the alarm with sensors at all entrance ways and several cameras. All worked well until I upgraded my doorbell cam to the latest and greatest. You do the math in money spent to have cameras not work correctly. Not to mention still waiting on the failed sensor response from the alaram that sent the police to my house 2 times in a week.