Ring keypad 2nd gen

Hi, I brought a new security alarm.
My keypad doesn’t not work.
I plugged it in and no lights comes on.
Battery symbol doesn’t appear when plugged in.
I pressed the reset button and the lights come on when pressing but when I take the pin out everything stops working.
I left plugged in and for hours nothing happened.
Is this faulty keypad I got in the box.

Hi @PriscillaP. Try a factory reset of the Keypad to see if it then starts working correctly. This Help Center page will show you how to do so and also provide other steps you can try. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

Hi Priscilla.
I’ve just installed this system, I thought I would charge the keypad, before Installing the system, however after an hour or so, nothing,
Yes I had pushed the connection into the charging point. But it had not fully clicked in place. So if the reset has not worked, try pushing the connection in hard, until you feel or hear a click, it is a bit harder to do than fitting into say a mobile.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.