Ring Alarm - Unable to connect or see Wi-Fi.

My Ring Alarm and Eero network have been playing nicely since March. A few days ago my base station lost Wi-Fi connection and been running off 3G. I’ve followed the instructions in the app to join another network but it can’t even see my network. The ring stickup cam under a metre (further away ) is working fine.

Tried the usual like rebooting the router but it hasn’t helped.

Anyone got any suggestions before I sit on the phone tomorrow waiting for help?

Hey there, @UK_Si. This definitely should not be happening, as Eero commonly provides excellent wifi coverage and the Alarm Base Station only requires enough resources for communication and status updates. If you are still not finding the wifi network when attempting to reconnect, or join network, please try using the “add hidden network” option on the network select screen in the Ring app. This option will allow you to manually enter your wifi information to connect.

As described in our help centre article, moving the Base Station closer to the router can also help maintain connection. As you mentioned the router being close already, the next best step will be to use ethernet connection for the most dependable network connection. I hope this helps! :slight_smile:

Considering the outdoor cams are not having an issue and it worked perfectly well for over a year, I don’t think Wi-Fi strength is the issue especially as both are owned by the same company! I think a phone call to technical support tomorrow is in order.

I suddenly started to have the same issue. I have google wifi. Ring is on cellular backup now but everything else is connected to internet. I even tried ethernet connection and still no go.