Privacy zone

I set up 2 zones…because they were not what i wanted i deleted them both. Im now trying to set them up and it says i already have the maximum setup. I rang thr helpline…she told me to login to someones elses phone to edit them so i did i get thr same message. Ive tried removing the app and reinstalling ive also tried rebooting the device…nothing changes. Can anyone help please

1 Like

Hi @Hels. Which model of Ring Doorbell or Camera is this happening on? If you have any other Ring devices, are you able to successfully add Privacy Zones on those devices? In addition to the troubleshooting steps you’ve tried so far, I would recommend also ensuring that your Ring app and your phone’s software are fully updated.

I have the same problem with my spotlight cam+. This happens on my Galaxy S22 phone and galaxy S8+ tablet. All firmware and software is up to date.

Uninstall and reinstall and factory reset didn’t help. I am able to setup privacy zones on my other camera without any issues.

Hi neighbors. Since you have tried the basic troubleshooting steps we would recommend, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

is there any update on this issue? i have the same problem. I think there is a bug in the firmware which needs to be fixed.