Invalid Multipass request

Hello.

I recently changed my email address working with Community Support. They were successful in changing my primary login account email address.

Now I have this issue when I’m navigating the ring.com website. Any time I select a menu to look into products I get this error:

Oops, something went wrong.

What happened?
Invalid Multipass request. The given email address is already used by another customer (with a different Multipass identifier).

Any ideas on how to solve this error?

Hey @wpcarroll. I would recommend that you log out of Ring.com and the Community site as well (all Ring related websites), and then clear your browser’s cache and cookies. Once that is all cleared, go ahead and log back into Ring.com and let me know if you’re getting that same error message!

I have the same issue on both Windows and iOS. Cleared cache and tried Incognito mode in Chrome. I can see my account, but when trying to get to the shop, to buy stuff :), I get the same error. Any additional info on how to fix it?

@Frisco Are you by any chance using a VPN? If you are, you will need to make sure you turn this off and try to access it again. If you are not using a VPN and still experiencing this, please reach out to our support team here so they can take a further look into this.

I am having the same error. I can log into my ring account, but cannot shop for items once there without getting this error:

Invalid Multipass request. The given email address is already used by another customer (with a different Multipass identifier).

I cleared cache and website data from all my browsers, attempted to use Firefox, Chrome, and IE. Still no joy.

Edward

Hey neighbors! If you are still having this error message when you are trying to shop or browse around in Ring.com, and none of the troubleshooting provided has helped, please reach out to our support team here. They will be able to escalate this concern to get it address and fixed by the appropriate team. :smiley_cat:

This issue is not necessarily related to change email addresses. I have not changed my email address since setting up my account but I am still getting the error under the following circumstances:

Log in to ring.com using 2FA without problem

Select Products from the top line menu.

I get this error with Chrome, Firefox (all history deleted before login) and MS Edge (new chromium-based version with all history deleted before login) in Win 10 Pro 64-bit.

It appears that there is a credential handoff problem between ring.com and shop.ring.com. I can open shop.ring.com, login (which takes me to ring.com) without problem. However, if I try to back to shop.ring.com, the Milituipass error shows up again.

@LV941 Thank you for providing that detail on your experience! This will help other neighbors that experience this as well know where to go from here. This concern has been isolated by our support team, and if you’re able to call into them here, they can escalate up your concern to get it resolved. This concern can happen for other users, but it is specific to your account. Once they escalate this up for you, they should be able to resolve this for you as soon as possible.

I have the same issue. I tried logging out, clearing cache and all the suggestions. I tried calling but I get an endless loop of let me connect you to sales. Followed by sales saying they can’t solve my issue let me connect you to tech support. I’ve had this issue since December and called in twice for help eith no luck.

Sorry to hear about this experience @Riffken! I can assure you that our support team is here and happy to assist with this. At this time, our chat and email support is not available, so reaching out by phone is the best way to get this resolved. As we always value our neighbor feedback, rest assured that I have shared this feedback with our teams here to ensure we are operating as efficiently as possible for our neighbors.

I have the same issue. I have called, chatted and emailed with support but still same problem no matter what browser, PC, MAC, etc I use. I was just sent the following email. what a joke.

Hi Edmund,

We have exhausted all troubleshooting options for this issue, if the issue persists - there is unfortunately nothing further that can be done to resolve it.

Here at Ring, your safety and security is our top priority. To protect your Ring account, you should take advantage of two-factor authentication (2FA) available in the account settings of the Ring app. Please consider enabling the 2FA feature in your account today. We also, recommend changing your password and making sure it’s different from any other password you use; it’s the best way to protect your Ring account. For more information on how to set up 2FA click here​.

Thank you for contacting Ring!

For more information, please visit ring.com or our online help at support.ring.com.

Zach
CS Tech Agent, Account Logistics
www.ring.com
If you need assistance in the future please check out our help center.
Download the Neighbors App.
Join the new neighborhood watch.

I just tried to purchase from Ring and am getting the same multipass error, getting the runaround that there’s a server issue and try tomorrow, it is tomorrow.
Changed our email address with Ring a few months ago and pretty sure that’s the problem

I just tried to purchase from Ring and am getting the same multipass error, getting the runaround that there’s a server issue and try tomorrow, it is tomorrow.
Changed our email address with Ring a few months ago and pretty sure that’s the problem

Hi all,
Same issue here, I can add to my cart, but when I view the cart or checkout I get the Invalid Multipass request error.

Any way to resolve this?

Sorry, but I find responses such as that to Edmond above quite remarkable. All that we are doing wrong here is we are trying to give Ring more of our hard-earned money for their products, and we are simply either getting blown off, or thrown into endless loops of incompetent support responses. I get that these complaints can’t always be immediately resolved through frontline support, but they at least need to be escalated until they are finally resolved by Ring’s best and brightest.

Anyways, from what I have been able to gather here, is that this is a universally known Shopify error message that we are getting here … therefore, I’m going to assume that the Ring Store services are being managed 3rd Party via a Shopify platform. Perhaps this is why Ring is finding it so difficult to resolve this problem … maybe it is somewhat out of their control?

Apparently, the problem arises when multiple devices are being used to sign into the Store (e.g. mobile phone, tablet, PC). If subsequent sign-in credentials on different devices do not remain “exactly” the same as what was in place in the initial sign-in device, this creates a conflict. My understanding is that this is not limited to the password being used itself … I’ve read that minor changes with account email addresses, or even a changed IP address can block entry into the Store. For example, one blocked customer had a letter in his email address capitalized in his initial sign-in, but not in a subsequent sign-in attempt.

The problem is, Ring customers cannot be expected to document and remember their original account sign-in credentials. This instead has to be managed by Ring. We are also encouraged to update our account information as we see fit over time.

I have been unsuccessfully trying to get this problem resolved with Ring support for several days now. We are working on it and have a nice day is not an acceptable response in my opinion. What troubles me is how long this issue has persisted (judging by the date of the initial post on this link). If anyone has any further insight on how to resolve this, I’d love to hear from you.

Same issue here, I can add to my cart, but when I view the cart or checkout I get the Invalid Multipass request .


Anyone knows how to fix the problem?

Hi there, @Javad. This should not be happening. Try changing your mobile device connection to wifi, instead of cellular data. I recommend also trying out another browser if possible. For further assistance with this, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Thank you :slight_smile: