Eero and a Ring Bridge

Quick tip: For the third time now, the only way to reconnect a Ring Bridge more than once to an Eero network (after it’s been deleted from Ring App) is to go buy a new one. I did try to talk with both Ring and Eero support and there seems to be a disconnect between the support teams on this.

I don’t know if it’s the network connection request that a Ring Bridge sends to Eero or the way that Eero handles the duplicate MAC address request, but it seems like there is a one-shot try to reconnect your Ring Bridge to an Eero network. If you have to do it again - it will never successfully link.

Just sharing my experience - 3 times over and 3 extra Ring bridges available.


This is odd to hear of, and certainly should not happen. There could be the possibility of a general IP conflict on a network, in which most routers will auto-resolve this or will have options to adjust. Try rebooting your network by powering down the network for a moment, then powering back on. Do this same thing with the Ring Smart Lighting Bridge to power cycle it. Try also resetting the Bridge with our support team.

I too have an Eero network and Ring Smart Lighting Bridge, and recently changed locations of these devices with a fresh setup in the Ring app. This worked as intended. There could be a setting in place here or even an interference. It sounds like you’ve likely explored most options and more,. as you’ve reached out to both support teams. Perhaps another neighbor will share some suggestions, or even a similar experience. Feel free to also return with any updates or observations that you find! :slight_smile:

In case any other neighbor experiences this, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

I’m currently have this same issue with my ring and eero network and for some reason I’m not able to get it connected back on to the network.

Hey, I just went through this whole situation and wanted to explain what worked for me.
DON’T disconnect your old router/wireless network until the new network on the Ring Bridge is added. For some ridiculous reason the Bridge (& our Gen 1 doorbell camera) could not connect to the temporary Ring network without having both wireless networks up and running. Once you get into the setup it will FINALLY connect to the temporary Ring network and then ask if you want to connect to the Eero network. You may have to put in your password for the new network. One all the Ring devices are set up on the Eero network, you can safely disconnect your old router. I wanted to add more expletives to this post, but instead I’ll finish with good luck and I hope this helps!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.