Ring video doorbell won't enter setup mode

Ring doorbell worked for a year then quit. I hard reset it and it worked a couple of days then quit again. I tried to reset again and won’t work. Blinks blue instead of spinning.

Hey @Bfbarnard, thanks for sharing your experience! Knowing that you’ve performed a hard reset, your Ring Doorbell should automatically go into setup mode after pressing the setup button again. If your Ring Doorbell doesn’t automatically go into setup mode or you cannot prompt it to enter setup mode, we recommend contacting our support team directly to see what the cause for the concern is. Could you please give our support team a call at one of the numbers available here? We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to come back and share how this goes, as your answer may help other neighbors!