Ring doorbell 2 not showing live view on 4g

Hi, I am hoping someone can help me. I have a ring doorbell and a stick up cam. I am able to access the live view on both with no issue when I am at home using my home wifi, but when i am away from the property and load the ring app using the 4G on my phone all I get is ‘activating device’ and it doesn’t load the stream. I am with EE in the uk by the way and I have also tried the ‘Rapid Ring’ app with no luck.

Can anyone help me or answer any of my thoughts on this

  • I have a moto g30 is it something in the settings on that, that is preventing me from accessing the live view?

  • If I reset both cameras and remove them from the app, can I re install them and it wont thing theres another camera on my ring monthly plan?

Many thanks

Sorry to hear about this, @gw84! Thank you for sharing all the steps you’ve completed, in which these cover most of the suggestions I would make here. I recommend also ensuring that there is not a vpn enabled on your mobile device. Try also attempting live view, using the Rapid Ring app, while in different locations to see if this concern is due to a different in cellular tower coverage.

As your Ring device and Ring app work as intended on wifi, this will indeed be best solved with mobile device settings. Other than the settings in your mobile device, your cellular provider or carrier (EE) will be the next best step, as they can provide assistance with your 4g connection. Feel free to let us know how this goes! :slight_smile: