Ring 3 new set up failing to connect to wi-fi

Hi I am trying to set up my new Ring 3 video doorbell. I have the app and, with the battery fully charged and inserted, I followed the instructions to connect to wi-fi and each time I get 2 flashing white lights on the right and message saying failed to connect.
The unit is sitting 2 feet from my router.
I carried out a router reset.
I carried out a Ring unit 15 second reset.
I have a good router signal strength, disconnected all other devices in the house.
I have re-configured my router to use a 2.4 ghz connection for the Ring.
I have turned off “mobile data” or “cellular data” on my iphone.
When I try to connect to my router using the settings app on my phone, the Ring sees the router and connects fine.
I have re tried numerous times, with the same result, two flashing white lights.
Is there anything else I can check, please check what I have done already before making suggestions, it’s not helpful to request I cary out the stages I have already done.

In addition to the above, I have tried switching my router channel to 1 and then to 11 with the same results, I don’t understand why my phone’s wifi system detects and connects to the Ring network but when I try through the app , it doesn’t connect.

for those interested, I have now sorted this out myself, my router is a Sky broadband router of the most recent. I had to add another IP address in my router set up which the Ring recognised and connected to instantly, I found this on the Sky help pages by just typing in unable to connect Ring 3 to Sky router. the instructions are very simple to follow. You will also need to split your router between 2.4 and 5 ghz and use the 2.4 ghz on any channel between 2 and 10.

1 Like