Pages for MyPlan and Account don't load in browser

The pages for ‘MyPlan’ and ‘Account’ don’t load in either Firefox or Chrome browsers.

A blank page [] with a ‘spinner’ below a Ring logo appears - and never loads any content.

Also, messages display in the lower margin : “processing request” - then “waiting for” - then “establishing secure connection” - then “processing request” again - without ever successfully completing.

I’ve allowed that page to attempt to load the entire time I’ve been typing this message, and that tab’s “wheel” is still just spinning - though the page is now completely blank - the Ring logo has disappeared.

I’ve tried in normal and private [incognito] modes - allowing third party cookies, popups, and redirects, with all referrers enabled.

As I recall, when I first installed and configured my Ring device[s] [of course I installed the Ring App on our phones and tablet[s]] - I purchased the Basic Protection Plan using a desktop browser.

I can view and manage [star and/or delete] video in a browser, but have been unable to access the pages for ‘MyPlan’ or ‘Account’ from a browser for a couple of weeks, at least.

What’s up with Ring’s servers - why don’t they seem to be able to retrieve those pages ??

I just tried on my computer with Chrome. I logged in and enter my code. Went to the site and clicked my plans. Everything worked fine.
Maybe try clearing your cache in Chrome and restating your computer.

I cleared cache, cookies, etc. and restarted computer. Also tried on another computer.

Still no joy - those pages simply will not load for me.

I am concerned because my Protection Plan is due to renew soon, and I had my credit card replaced - it has a different CV code and and new expiry date.

Elsewhere in this forum, people have reported that they have had problems changing their CC info in the app and on the website. Like those people, I will NOT give my CC info over the phone to any person - especially one on another continent.

I anticipate having to allow my subscription to the Protection Plan expire before I will be able to purchase a new plan - though I would rather not be in the position of losing video recording/cloud-storage during any gap.

I am just trying to get ahead of these concerns - and seriously doubt Ring support would be of any real help. Usually they advise customers to call - and/or uninstall/re-install their apps.

Are you in the US? I’m in the US, maybe that’s why it works for me and not you. Funny how I have no issues but you do. Very strange…

I am in the US - and there’s nothing funny about it.

I speculate that it’s possible your experience and mine differ because you might be accessing that content via an AWS server that may be configured in a way thats not consistent with the server for my region or internet segment.

Ring should monitor these community forums and address the issues that their customers encounter - especially issues that impact critical aspects of the functioning of the customer facing website.

I intend to send an email to Ring Support describing the website problem in detail - hopefully they will be able to diagnose and remediate.

I was able to update my CC info in the app - though I generally avoid sharing any sensitive data using any android device.

As you may be aware - your mobile device[s] present a much larger attack surface than your modern desktop browser.

Additionally, the coders for most ‘mobile’ apps are notoriously sloppy - and many third party apps by design eavesdrop on your activity even when they appear to be inactive - sending your data to fourth parties that have no business with you or your data - turning your data into profit - and passing it on to other ‘partners’ to aggregate.

I’m trying to help you and you get all *edited* on me. No wonder you couldn’t do it. *Edited* but job as well. Sorry for trying to help you. Enjoy your life. I’ll stay far away from *edited*
*Edits by eagle328*

Hi @MobileMike are you able to send a screen recording of this? Also, can you please clarify if you are using cell network or wifi? You also mentioned being on two browsers…Can you please let me know what operating systems your computers have? Were both computers connected to the same wifi network? Thanks!

@Jennifer_Ring Community Manager

First of all, I think it’s a stunning bit of hypocrisy that Eagle328 is allowed to insult anyone on this forum - above in this thread:

“I’m trying to help you and you get all crazy on me” and [sic] “Tim foil hat but job as well”

Further, somebody decided that the links I posted here illuminating poorly or maliciously coded apps, and the attendant privacy and security concerns, in response to Eagle328’s insulting remarks were somehow inappropriate, and deleted that response, which preceded your inquiring about my browsers and computers and network.

Second, if you bothered to read this thread from the top, I stated:

“The pages for ‘MyPlan’ and ‘Account’ don’t load in either Firefox or Chrome browsers.”


“A blank page [] with a ‘spinner’ below a Ring logo appears - and never loads any content.”

Third, you will be pleased to know that the website issue seems to be resolved - please note that

The URL[s] in the address bar now are:

which are different URL[s] than when I first inquired about this issue:


The website that was loading in my browser when I started dealing with this time-sink had the wrong links coded, and now the correct links are available to me - apparently because somebody at ring finally realized that the problem was on their end.

I’ve repeatedly tried to help you on other threads as well. On this one you came off as hostile to me. Sorry I hurt your feelings. I thought it was all behind us but ok. Guess it’s not. I’ll remove the bit of comment above so it can no longer cause you any issues. I’ll refrain from interactions with you from now on until we’re allowed to block others. Good day.

Sure Eagle - Cover your tracks

@MobileMike I did read your initial post, which is why I asked, “You also mentioned being on two browsers…Can you please let me know what operating systems your computers have?”

I also sent this post to the correct team to review and asked the questions they needed answers too. It seemed to be user error, as it is working now and the team hasn’t done anything. I’m so glad everything got sorted out.

Please, again, acknowledge the Community Guidelines – we will not tolerate trolling or bullying to one another especially moderators. We will take necessary action when moderating posts and users within the Community. @Eagle328 , same goes to you – even though you’re trying to help lets remain friendly towards one another & thank you for editing your previous comment. The Community is a peer to peer forum to receive assistance to your questions. It is not a direct line of support and if you need more in depth assistance, it is suggested you contact our 24/7 support team.

I hope you have a nice day.

1 Like

Have a wonderful day now…

@Jennifer_Ring Community Manager

Due to the fact that the situation resolved without me changing a single thing on my end, I can only guess at what might have changed on the AWS/Cloudflare end of things.

But I too am very glad the links got sorted out.

I don’t know if you ever had the opportunity to view or read the inexplicably deleted post that I offered so that others could explore and educate themselves regarding genuine privacy and security concerns.

It was a collection of links, and was offered with the intention that reader[s] might find the information interesting and useful.

I am dismayed at any suggestion I have ever trolled or bullied on this forum.

Bottom line,

Thank you - I hope you have a nice day too!

@Eagle -

I can see how my frustration at the situation may have seemed to you.

Sorry if it seemed I was hostile to you, or if I hurt your feelings - that was NOT my intention.

It is all behind us as far as I’m concerned.

Hope you have a wonderful day.

Thank you. We were both having a rough day that day. Sorry for my comments.

It’s all behind us. Let’s move forward and forget that day.

Hope you day is going well too.

I am having the same trouble- account pages won’t load. Two different browser- two totally different domains. I tried @mobilemike links but they both failed. Any suggestions would be appreciated.

Hey @Michelle2, please try this link to get to your accounts page: You will need to make sure you are logged in first. Please note that you will only have access to the Control Center in the app, if this is what you are looking for!