cancel
Showing results for 
Search instead for 
Did you mean: 

Ring doorbell does not charge

Highlighted
New Neighbor

Ring doorbell does not charge

Hello

Yesterday I removed my Ring door bell to charge using an outlet. When I connected the micro USB to the door bell it did not turn on (flashing blue lights). The lights do not turn on. I tried multiple outlets and charging cables still no luck. Is the door bell battery gone bad?

 

This did not happen before till I connected my door bell to the solar charger. Not sure if that had anything to do with it.

 

Aditya

1 REPLY 1
Highlighted
Community Moderator

Re: Ring doorbell does not charge

Hi @vaidyaadi! You've certainly covered all the best first steps to get this to work. After allowing it to charge for awhile, or leaving it plugged in to the charger, if the Doorbell is not charging please attempt a reset by holding the setup button for 20 seconds. 

 

After resetting your Doorbell, and allowing it to charge for some time, please attempt a new setup in your Ring app. Your device should connect and show as charged. If it does not, our support team will be able to assist with further troubleshooting steps. Smiley Happy 



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.