cancel
Showing results for 
Search instead for 
Did you mean: 

Ring Pro won’t enter setup mode

Highlighted
New Neighbor

Ring Pro won’t enter setup mode

My ring pro will not go into setup mode. I had the first generation ring hardwired so I know everything works. I even got the WiFi extender chime time rule it out but it simply will not go into setup mode. It will not show a spinning white light. Just a pulsing white light. Below is the troubleshooting I’ve done.

1. Tried bypass mode on the v2 pro power kit and also installing it normally.

2. Held down orange button for 30 seconds to do a hard reset. This results in the white light pulsing. Never spins.

3. When going through setup on the app it asks to connect to ring network but it never completes.

4. When connecting the ring pro using the WiFi extender chime, it never finds the ring pro.

5. The ring pro will chime and blink blue, but it won’t connect to the app.

6. Tried connecting directly to WiFi and even restarted modem.

It seems like it’s stuck in limbo. If there’s another way to hard reset, I would like to know. Otherwise I need a replacement. Thanks!
18 REPLIES 18
Highlighted
New Neighbor

Re: Ring Pro won’t enter setup mode

I have the same issues

Highlighted
New Neighbor

Re: Ring Pro won’t enter setup mode

I have the exact same issue with my Ring Pro. I was able to set up my Ring 2 smoothly but not with this one. 

Highlighted
Community Manager

Re: Ring Pro won’t enter setup mode

Hi neighbors - have you been successful at setting up your device? I know its been a day so wanted to get the most up to date information Smiley Happy

 

 

Got a question? The Community is full of answers! Use our Search bar at the top for quick results.
Highlighted
New Neighbor

Re: Ring Pro won’t enter setup mode

My ring pro still will not enter setup mode

Highlighted
New Neighbor

Re: Ring Pro won’t enter setup mode

Hi Jenifer, 

 

My issue with the ring pro is as below:

- Ring pro stuck with a soft white glow. 

- After I long pressed the side button, it seems to do a reset and after about 1-2mins, the top half is blinking in blue color. 

- If I press the doorbell button, the chime will sound and the light wheel will spin in blue. After about 5 mins, the light turns solid blue for a short while before the top half is blinking in blue again.

- Pressing the side button once does not do anything. 

- Ring Pro was left connected to the power for a whole day before setting up. 

- Ring Pro is connected with the provided ring adapter so there should not be an issue with voltage. 

All in all, I still cannot set up my Ring Pro. Please let me know what will Ring do to resolve this matter. It seems like a common issue with all the Ring Pro since I don't have any similar issue with my Ring 2. 

 

Regards,

QT

 

Highlighted
Community Manager

Re: Ring Pro won’t enter setup mode

Hey neighbors! Thank you for following up with us here and detailing more of what you have done to get this resolved. Since this is still to no avail, we recommend contacting our support team directly to see what the cause for the concern is. Could you please give our support team a call at one of the numbers available here? We're taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.
Highlighted
New Neighbor

Re: Ring Pro won’t enter setup mode

I’m having the same issue. It was working fine until one night around 1:30am. Now it just pulses white. Won’t enter set up mode. I even changes transformers just in case. No help.
Highlighted
New Neighbor

Re: Ring Pro won’t enter setup mode

I have the same issue. Contacted ring a number of times. Now I am planning to return the doorbell back

Highlighted
New Neighbor

Re: Ring Pro won’t enter setup mode

Hi Jennifer,

 

I tried contacting Ring Support through chat and was sent the Pro kit.

I installed the pro kit as advised but still no progress

The button keeps flashing blue without entering setup mode

Tried various strategies: Hard resetting, soft resetting ... no way of getting it to work

Would it be possbile to return it back for a Doorbell 3 plus or a refund ?