cancel
Showing results for 
Search instead for 
Did you mean: 

Stickup Cam shows not connected to WiFi

SOLVED
Highlighted
New Neighbor

Stickup Cam shows not connected to WiFi

My Stickup Cam is showing as being offline in the Ring app, but my router settings show it as being connected. I've restarted my router - didn't work. I power cycled the cam - didn't work. Any advice?
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Manager

Re: Stickup Cam shows not connected to WiFi

Hey @DeviceMX. Have you tried the Reconnect to Wifi option through the Device Health section in the Device's Profile? This is great step to try as well, and let me know if it's able to reconnect this way! Smiley Happy 



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.

View solution in original post

8 REPLIES 8
Highlighted
Community Manager

Re: Stickup Cam shows not connected to WiFi

Hey @DeviceMX. Have you tried the Reconnect to Wifi option through the Device Health section in the Device's Profile? This is great step to try as well, and let me know if it's able to reconnect this way! Smiley Happy 



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.

View solution in original post

Highlighted
New Neighbor

Re: Stickup Cam shows not connected to WiFi

I am having the same problem. I've restarted my router and reconnected the cam via the app but, within a few minutes, shows no wifi connection in the app, but, my router shows it is connected.  Did you ever get this resolved?

Highlighted
New Neighbor

Re: Stickup Cam shows not connected to WiFi

I've got the same problem, tried these solutions, and it didn't resolve the issue. Please help.

Highlighted
New Neighbor

Re: Stickup Cam shows not connected to WiFi

I had to open it up, hold down the orange button, and reconnect to WiFi. That took care of it.
Highlighted
Community Manager

Re: Stickup Cam shows not connected to WiFi

Hey @CRHT. It sounds like you may need to adjust your ports and protocols to ensure the Ring device can stay connected. Although it says connected to your router, there may be some restrictions that disallow the device to stay connected through the Ring app for you. Please review our Help Center Article here to see if making these changes helps with your device's performance!



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.
Highlighted
New Neighbor

Re: Stickup Cam shows not connected to WiFi

Thank you for your response. I read the article and it is confusing to me. Prior to me calling my ISP (comcast), I wanted to reach out and let you know that I have seven (7) ring cameras on my network and only one of them has this issue. I say this because I wonder if it is my router settings when 6 of the 7 cameras work. Also, I've had this camera for over a year and the problem just started. 

Highlighted
Community Manager

Re: Stickup Cam shows not connected to WiFi

@CRHT Some routers have device limits that only allow a certain amount of devices to connect at one time. In addition, some routers may get settings reset during firmware updates to the router which will not affect other devices already on the network, but any future ones to be added or recently added ones. It's simply a hunch, so worth a shot to make sure your network settings are checked. For more individual help with your specific device, you may also want to call our support team here. They can isolate this down quickly and easily for you too! 



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.
Highlighted
New Neighbor

Re: Stickup Cam shows not connected to WiFi

That was one of the first things I tried...does not work.  I’m having this problem continuously.  Ring used to be the best on the market, then sold to Amazon.  They discontinued my stickup cam model, and changed their extended warranty verbiage.  Not as good.