cancel
Showing results for 
Search instead for 
Did you mean: 

Stick up cam and solar panel not charging

Highlighted
New Neighbor

Stick up cam and solar panel not charging

I've had my Ring solar panel connected for 4 sunny days and it is not charging my Stick Up Cam. It still reads 3%. I've checked the connection and nothing is changing.

When I bought the solar panel, it said it would work for the Stick Up Cam.
7 REPLIES 7
Highlighted
Community Manager

Re: Stick up cam and solar panel not charging

Hey @Schnoomom! When you go into your Ring app > Main Menu > Devices > Device connected to solar panel > Device Health, does it show that there is a solar panel connected? If your app is not showing the solar panel as connected under your Device Health page, you will want to ensure the device is connected properly. I recommend detaching the solar panel from your device and then attaching it back, while also ensuring that there is no dust and debris on the solar panels and at the connection. 

 

After checking the connection, if you find that it is still not showing as connected in the Device Health section, please try resetting your Ring device (not the solar panel) by pressing and holding the setup button for 20 seconds. After this reset, re-establish the connection your device has in your Ring app by tapping on Reconnect or Change Wifi Network under Device Health. This will take you through another setup of the Ring device in the Ring app. Once completed, check the Device Health again to see if the solar panel is showing as connected. If the device is showing as connected, please ensure you are getting 4 or more hours of direct sunlight to the solar panel during the day to allow a trickle charge to your device. You will also want to ensure that your device is not discharging more than it is charging, as you may have an excess amount of events that could be draining the battery on your device. 

 

In the event you may not see the solar panel connected still, please give our support team a call at one of the numbers available here. We're taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.
Highlighted
New Neighbor

Re: Stick up cam and solar panel not charging

I’m having the same problem. I’m losing more battery charge since I installed the solar panel.
Highlighted
New Neighbor

Re: Stick up cam and solar panel not charging

I have had the exact same issue. Personally I think the solar panel with stick up cam combination is a scam. Even though e company says it should work it doesn’t. Ring/Amazon should give everyone who bought this combo package a refund. Or upgrade to spotlight cam for free. Apparently that is the only combination that really works.
Highlighted
New Neighbor

Re: Stick up cam and solar panel not charging

Fixed: I have had the same problem. Battery not staying charged when on solar. 1 to 2 days max before i had to remove and rechage while connected to solar. It is fixed and its been a week and still at 100% I called customer support and they walked me thru a few settings. It turns out they have settings they can see that we can not see in the app. They had me change the power mode in the general settings to battery then push and hold the reset button on the bottom for 20 seconds so it would reboot. "settings/ device settings / general settings/ power mode" 

 

It use to show the solar add saying click here to add to your system or something like that. Now it shows nothing. I dont know if the help desk changed any thing or not but I am no longer having the issue. Good luck and I hope this helps some one.

Highlighted
New Neighbor

Re: Stick up cam and solar panel not charging

Having the same problem, over and over again.
I have called and been told to change settings, so I did that and even bought a chime Wi-Fi extender and still have the same problems
Highlighted
New Neighbor

Re: Stick up cam and solar panel not charging

So I’m 20 feet up in the air on a ladder, in -8C snowing, and I secure the camera, and solar panel both with the optional gutter attachments. I had charged the battery and did the camera setups in the house before putting them up on the roof gutter. I then plugged in the solar panels in each when I got up to the roof eaves. After coming down and putting the ladder away, I get a notice saying I now have external power and I need to press a button inside the battery bays, remove the batteries in each cam and go through the setup all over again, all in the cold, on a ladder, 20 feet in the air, and snowing. I have gone through all of the instructions on every piece of paper that was included with the cams and solar panels and NOWHERE does it say you are required to plug in the solar panel while in the house doing the setup. This really needs to be put in the instructions somewhere, anywhere, that the solar panel absolutely must be plugged in before installing the cam and solar panel on your #%^}~ing roof!!!! Well I guess I’ll see how long the batteries last on these 2 cams, I’m hoping till spring but I doubt it. I’m extremely disappointed in this setup and lack of plain, prominent, installation information that comes with the cam and solar panels. I also just installed a doorbell 3 and there is no automatic pop up when the doorbell rings, that is a whole other kettle of fish. Is there any way that anyone may know that I can get the solar panels operational without climbing back up on the roof and bringing them back down and starting all over again? Any assistance would be greatly appreciated!!!
Highlighted
New Neighbor

Re: Stick up cam and solar panel not charging

I'm having the exact same issue. My Ring ustick p cam has been losing about 1% per day. It has about 4 hours of direct sunlight per day in the morning and it never seems to charge the battery at all. When I look in the settings its says it is connected to the battery under power source.