cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Get Past Initial Set Up

Highlighted
New Neighbor

Can't Get Past Initial Set Up

I purchased a ring Stick Up Cam Battery and an indoor Cam and I am having the same issue with both, I can't get them to set up. The problem is the same for each. I follow the direction of powering them up, following all directions. They enter set up mode with a blinking blue light and then they'll not connect. The next screen on the app appears asking what light I see and the camera is still blinking blue. I have reset my router, reset the camera, uninstalled and reinstalled the app, I have high-speed internet and I am sitting in front of the router during set up. Where am I going wrong?

3 REPLIES 3
Highlighted
Community Manager

Re: Can't Get Past Initial Set Up

Hey @Adltal. When you try to set them up, as you unable to connect to the Ring AP, or your wifi password will not be processed for you to finish setup? If you can, please make sure all ports and protocols are adjusted to allow the Ring devices to connect, and if you still get stuck, give us a screenshot of where you get hung up! 



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.
Highlighted
New Neighbor

Re: Can't Get Past Initial Set Up

Thanks for the response. Sorry, I never got notified of it so I never noticed. Anyway, here is where I am getting hung up in both cases. My phone switches from my wifi, MJRJ, to the Ring wifi to complete the setup but my camera stays blinking blue as in start-up mode. 

 

I am not familiar with ports and protocols or how to change them. I was never asked to put in a wifi password anywhere. I just followed the directions on the app for the setup of each device.

 

Thanks again for your help.

Highlighted
Community Manager

Re: Can't Get Past Initial Set Up

@Adltal Thanks for getting back to me, and no worries! It seems the device is unable to connect to the Ring AP, which is that setup network it keeps prompting you to connect to. Could you try resetting the device by pressing and holding the setup button for 20 seconds? After this time, wait a few minutes for the device to reset. Once reset, please attempt another setup, ensuring you have Bluetooth on. I also recommend to maybe disconnect your phone from your home wifi network that it is connected to, so that way when you join the Ring setup AP, you won't have to worry about the networks having to switch over, as wifi will not be connected at that time. 

 

In the event you still cannot set up the device, please give our support team a call at one of the numbers available here. We're taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.