cancel
Showing results for 
Search instead for 
Did you mean: 

Pages for MyPlan and Account don't load in browser

SOLVED
Highlighted
Community Manager

Re: Pages for MyPlan and Account don't load in browser

@MobileMike I did read your initial post, which is why I asked, "You also mentioned being on two browsers...Can you please let me know what operating systems your computers have?" 

 

I also sent this post to the correct team to review and asked the questions they needed answers too. It seemed to be user error, as it is working now and the team hasn't done anything.  I'm so glad everything got sorted out.

 

Please, again, acknowledge the Community Guidelines -- we will not tolerate trolling or bullying to one another especially moderators. We will take necessary action when moderating posts and users within the Community.  @Eagle328 , same goes to you -- even though you're trying to help lets remain friendly towards one another & thank you for editing your previous comment. The Community is a peer to peer forum to receive assistance to your questions. It is not a direct line of support and if you need more in depth assistance,  it is suggested you contact our 24/7 support team. 

 

I hope you have a nice day. 

 

 

 

Got a question? The Community is full of answers! Use our Search bar at the top for quick results.
Highlighted
Neighbor II

Re: Pages for MyPlan and Account don't load in browser

Have a wonderful day now...
Highlighted
New Neighbor II

Re: Pages for MyPlan and Account don't load in browser

@Jennifer_Ring Community Manager

 

Due to the fact that the situation resolved without me changing a single thing on my end, I can only guess at what might have changed on the AWS/Cloudflare end of things.

 

But I too am very glad the links got sorted out.

 

I don't know if you ever had the opportunity to view or read the inexplicably deleted post that I offered so that others could explore and educate themselves regarding genuine privacy and security concerns.

 

It was a collection of links, and was offered with the intention that reader[s] might find the information interesting and useful.

 

I am dismayed at any suggestion I have ever trolled or bullied on this forum.

 

Bottom line,

Thank you - I hope you have a nice day too!

 

 

Highlighted
New Neighbor II

Re: Pages for MyPlan and Account don't load in browser

@Eagle -

 

I can see how my frustration at the situation may have seemed to you.

 

Sorry if it seemed I was hostile to you, or if I hurt your feelings - that was NOT my intention.

 

It is all behind us as far as I'm concerned.

 

Hope you have a wonderful day.

Highlighted
Neighbor II

Re: Pages for MyPlan and Account don't load in browser

Thank you. We were both having a rough day that day. Sorry for my comments.

It's all behind us. Let's move forward and forget that day.

Hope you day is going well too.
Highlighted
New Neighbor

Re: Pages for MyPlan and Account don't load in browser

I am having the same trouble- account pages won't load.  Two different browser- two totally different domains.  I tried @mobilemike links but they both failed.  Any suggestions would be appreciated. 

Highlighted
Community Manager

Re: Pages for MyPlan and Account don't load in browser

Hey @Michelle2, please try this link to get to your accounts page: https://account.ring.com/account/app/my-details. You will need to make sure you are logged in first. Please note that you will only have access to the Control Center in the app, if this is what you are looking for!



Like my answer? Accept it as a solution (click on the 'Accepted Solution' button next to reply). Learn more about the Community, here.