cancel
Showing results for 
Search instead for 
Did you mean: 

Ring doorbell pro keeps entering setup mode

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

I updated existing transformer to 30VA one (see amazon link)

https://www.amazon.com/gp/product/B07GND8RMQ/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

also updated mechanical doorbell to the one in the ring compatible list (I bought Hamptom Bay's one)

https://support.ring.com/hc/en-us/articles/209028546-Ring-Video-Doorbell-Pro-Chime-Kit-Compatibility...

This is because to prove nothing wrong my configuration or wiring, but it resulted same, the device went to the offline.

 

Today, finally, I was able to speak to the tech support guy, and accoring to him my Ring doorbell had failed (actually rjected) to update the new firmware. And then it went back to the setup mode after the certain amount of time. I don't know what actually wrong in my end, but I strongly feel that there's a problem in the device itself. I will keep trying to discuss with them.

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

[RESOLVED]

I tried more than 30 times, and finally made it work!!!!  It was pretty simple.

 

  1. Press the ring button 20+ secs to make it setup mode.
  2. From Ring app, setup the device with wifi SSID and password. The device work for a while, and it seems that the device attempts to update its firmware.
    • If you just wait, then the device comes back to the setup mode in about 5 min.
    • However, during its online (first 5 min), enable "Motion snooze" for 2 hours from the app, then the device seemed successfuly updating its firmware. Yay!!!
  3. It works my mecanical chime. also Alexa integration works well.

I tried this step only once, so I am not sure it works in everyone's case. Please try and if it works, report here. Ring tech said they are continuously monitoring this forum. 

So far, the device still works more than 1+ day after the setup.

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

tried this for mine and it still goes into setup mode after about 5 minutes

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

mine also does this! ive tried everything!

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

I just bought mine, set it up and ran into the same issue! Been messing with it for 4 hours. I'm done.
Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

Well everyone - you might all be trying but I think I hold the record!

My Pro doorbell was installed in February 2020 and it worked absolutely fine for around 6 months. I added a driveway camera to the system and that was fine too. Then, 22nd July the doorbell stopped working. It has a plug in chime that came with it and it is plugged in literally 18 inches away from the door, there is nothing from an old doorbell in the system, all new provided by Ring and the sparks says he followed the instructions to the letter.

The call centre at Ring provides me with diffcult to understand people who try and say that we installed it incorrectly. I hired a professional electrician and had it wired into my consumer unit so the Ring transformer actually takes up the last 2 spare "ways" in that. I fail to understand why it suddenly doesn't work and only yesterday spent another 30 minutes on the phone trying to convince the support member that the bell needs replacing.

I cannot press the setup button on the side of the bell and get any response, no matter the length of time pressed. 

I was told in July that I was missing a Ring Power Pack - a really thin bit of plastic with 2 wires that apparantly needs to be placed into the consumer unit, although where it would be so the cover can be fitted is extremely difficult to understand. They didn't send me one in July and they say they are now sending me one but we will see. I asked for a replacement and the chap simply said I should have returned it within 30 days.

Well Ring. I am the sort of person who doesn't take crap lying down and I will go to the County Court if I need to, in order to get a working bell or my money back. I have paid for the web recording annual subscription and currently have been unable to use that effectively for nearly 2 months. I expect Ring will require me to fit this device but I am not sure that will be safe and it will cost extra if I call back the electrician.

I am giving this 7 days to get resolved, then I am filling in the court forms.

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

I was a person who wrote [RESOLVED]. It had worked well for about a month, in motion sensing, capturing video, also live video. I really enjoyed with Ring device in the month.

 

However it stopped working since a couple of days ago (it seemed that the timing of firmware update), and got into same situation again. This time, disabling motion sensing or snooze didn't effect at all. I've heard "Rome wasn't built in a day" about 50 times (means I've tried various things ;-) as much as I can). My Rome won't be built forever. The wifi strength is excellent (RSSI -35), and voltage is 4048mv which is Good,  also I've  replaced the transfomer with the recommended version (16v 30va) since since Aug 22, and also replaced mechanical doorbell with the compatible one. 

 

From my observation, it seems that the problem is related to the frimware update during setup mode. As everybody mentioned, it works for first 5 min after setup. Right before crashing, LED flases a couple of times (White solid ring), then it comes back to setup mode with the voice announce.

 

I looked around a lot of forums, facebook pages, reddit posts, and found that a lot of people struggled with the similar problem. As a software engineer, I say this was caused by a problem in quality assuarance in Ring company. They should test it the new firmware with ALL possible hardware versions before releasing new firmware. 

 

Hope the new firmware released very soon that cures my device problem.

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

After my previous comment, I tried various thing another 30 times, but never solve. The symptom was simple. Setup succeeded once. During working time, the ring button works and able to do video / voice communication, but after several minutes, white LED flash a couple times (the sign of firmware update) and then it returns to setup mode (with voice announce). Weird that it worked perfectly for a month, thus I suspect that this is firemware issue. Contacting support team is really time consuming but I will talk to them again to request replacement. I would like to hear from others how you solved the issue.

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

Add mine to the list too - 7 hours in and I'm giving up- adding together all of the time everyone has spent on this I think finding a permanent solution is unlikely. 

Exactly the same issues, exactly the same outcome. No one has posted a solution so its back in its box tomorrow and returned.

Highlighted
New Neighbor

Re: Ring doorbell pro keeps entering setup mode

I have just had my firmware updated by the people at ring after spending hours trying to sort it myself, had to send them a picture of the way it was wired before they would do anything, which I did and he was happy with it. Then it was done over the phone, had to give them access to Amazon account so they could do it and fingers crossed it seems to be working.