cancel
Showing results for 
Search instead for 
Did you mean: 

Chime "Setup didn't complete"

Highlighted
New Neighbor

Chime "Setup didn't complete"

Hi there,

 

I've tried every suggestion I could find so hoping someone may have an answer here.  I bought a Chime with my Video Doorbell to compliment the three other Ring cameras we have.  The Doorbell (and all the other devices) have connected fine to our Google Wifi Mesh but the Chime will no complete the setup.  Being diligent, I've tried the following:

 

1. Connecting to the Google Wifi, within 1 foot of one of the Wifi APs and 3 feet of the Doorbell

2. Connecting to the Primary Wifi AP

3. Connecting to an SSID that runs directly from my internet modem/router - same internet connection but different SSID/network

4. Connecting to the network at my office

5. Connecting to a personal hotspot on iPhone, Samsung Galaxy and laptops

6. Running the app from various iPhones and Android phones

 

The result on all is the same - I can select the Wifi network I want the chime to join, it sends my phone back to it's original Wifi network, tells me "Chime is joining the wifi network" and then eventually times out and says "Setup didn't complete" and I need to reset the Chime and start again.

 

The thing is, the Chime does connect to the network, I can monitor it getting an IP and transmitting data over a long period of time and I can even login to the mysimplelink page using the assigned IP.  The problem seems to be with the Ring app/Ring servers recognising the Chime? Keep in mind this is from many different phones and many, unrelated networks.  This is also the only device we have issues with.

 

Any ideas/suggestions?

17 REPLIES 17
Highlighted
New Neighbor

Re: Chime "Setup didn't complete"

My Chime setup tells me the network isnt available . BUT everything other device is working. ??

 

Highlighted
New Neighbor

Re: Chime "Setup didn't complete"

The same problem here

Highlighted
New Neighbor

Re: Chime "Setup didn't complete"

Thank you for your post, I have the same problem.  Did you ever get it resolved?

Highlighted
New Neighbor

Re: Chime "Setup didn't complete"

no, tried lot of times, with an open SSID, away from router.........but no way to get it working.

Highlighted
New Neighbor

Re: Chime "Setup didn't complete"

Thank you for the update. I spoke to the online support and went through setup via a mobile hotspot and guest wifi as well as my wifi, all with the same result that it failed completing setup. They are sending a replacement chime.
Highlighted
New Neighbor

Re: Chime "Setup didn't complete"

Thanks I will return mine as well and try another as well

Good Luck 

Cheers

Highlighted
New Neighbor

Re: Chime "Setup didn't complete"

I also went through online support and am getting mine returned, though I don't have high hopes as these things seem to be very problematic. I'm hoping that a new one will have updated firmware on it that resolves the issue.  What I really wanted was a refund so I could buy the (cheaper) Amazon Echo Dot which would work a sa Chime and allow voice control etc.  Oh well...

Highlighted
New Neighbor

Re: Chime "Setup didn't complete"

I have exactly the same problem. Tried everything you did and nothing works. Brand new unit. If anybody has a solution it will be appreciated. I am in South Africa so calling the US support number will turn out more expensive than the chime itself.

Highlighted
Neighbor II

Re: Chime "Setup didn't complete"

Call Us
US: +1(800) 656-1918 (24/7)
US: +1(888) 981-8993 (Español - 24/7)
INTL: +1(310) 929-7085 (24/7)
They do have an international number