Windows 10 App Live View on version 2.4.18

I am not able to live view from windows app on my PC for both door bell and indoor cams. It keeps giving me IOError.

Windows 10 Enterprise - 1809

Does any one else have same issue?

Hi @KalMine. Could you try removing the Ring app from your Windows PC, rebooting your PC (turn it off/on) and then reinstall the Ring app? Once reinstalled, try to load a Live View, and if you continue to get this error message, please attach a screenshot of this error message so I can forward this onto the appropriate team in order to be looked into further. Please note that if you have a VPN enabled on your PC when loading the Live View that this may also be prohibiting the Live View from loading, so make sure to disable this as well before loading the Live View.


Thank you for the response. I tried your resolution but still getting the same error. I have atached the picture as requested.


@KalMine Thank you so much for getting back to me and doing this! If you could, can you please reach out to our support team here in order to report on this as well? That way they can take a deeper look into this for you. Additionally, if they cannot fix this still for you, this will be so it can be documented on your account and when we have a fix for this concern you will be able to get updated accordingly as soon as it happens.

I’m having the exact same issue. Would love to know if you found a fix.

Not really. I called Ring & they have no clue what I am talking about. They only said restart my computer twice.

Interestingly it works on my wifes work computer. So, my guess in some permission settings but unable to figure out what?

Exact same issue I’m having. Wife keeps saying she has no problem connecting and I end up yelling at my computer. I considered the possiblity that if both of us are attempting to view at the same time, that it might cause the issue, however this proved false. Still happens. I’m close to scrapping it and going with a different brand doorbell.

Double check that you are not logged in to a VPN. I had the IOError, but when I turned off the VPN it worked fine.

1 Like

Didn’t work.

Yep! always did. Restarted computer and before doing anything else tried Ring App - As you know restarting computer cancels VPN - So, I am 100% sure tried and didn’t help.

Thank you for the sugeeston though!