Website rejects valid credit cards

Has anyone else had this issue?

I was trying to purchase the Protect Plan on the website, and found that the web page rejects all valid credit cards (at least all the ones I tried). The credit card information box border turns red, indicating an error, and the “next” button locks, but no error message is given.

I completed the purchase with a call to tech support and making the purchase over the phone, but posted here, because if others are having the same problem, Ring needs to know about it!


Thanks for sharing this feedback. May we ask what country you are located in?

I’m in the USA!

“Failed to add payment method.”

I’m having the same problem. Called the credit card company and they said MAYBE ring is trying to run it as a debit without permission?

If it’s not run as a credit card, it doesn’t work… company says the card has a zero balance and is active, so a $6 charge is nothing.

1 Like

It might be best to call our support team, who will be able to take a further look into this for you. They can be reached at 800-656-1918. Thanks!

Did you ever get a resolution on this, I am having the same problem, it will not let me purchase a protection plan?

The issue continues. My credit card would not process although I called and they assured me that they were not denying the purchase.

1 Like

Same thing happening in UK. Have tried multiple cards and multiple browsers, just will not accept the payment type. Please get this sorted.


I did get my problem resolved, I had moved a month earlier and my bank had my new zip code wrong. If the address with the bank or the credit card is not identical it will reject your card. That was my situtation, I wish the rejection would have been a little more specific.

We are having the same issue unfortunately. We also moved a few months ago but our bank is convinced the right email address is listed against the cards we used.
Spoke to two different customer service reps and the solution appears to be contacting the UK branch to give my card details over the phone. Slightly hesitant given that other people have recently tried this and are clearly not having much luck.

Rang my bank to confirm the details they had on record were correct with regards to billing, postcode etc.

Card then worked the following day. Hope this helps

I have the same problem. I transferred my Ring from a doorbell to a Security Camera and called to reactivate my account. For some reason, the system rejected my previous credit card, even though nothing has changed. When I went in to update my card, a box appears titled “Payment Method”. When I click to update my info, the box momentarily appears that would allow me to do that, then it goes away. So, I am unable to update my information - despite nothing having changed. When I go to the support I get stuck in their terrible Loop where I have to enter everything over and over. Why is it we can’t talk to a person and instead get stuck in some useless chat where nothing is solved? If this is supposed to be RIng’s idea of a better system, I seriously doubt how intelligent they must be. It’s supposed to be customer service, not customer frustration. Either fix this or cancel my protection plan. I’m in Missouri. I tried it on my iPhone and my computer. Same result.

The problem was only solved for me by calling and dealing with a representative. She tried to enter the information from my card twice and it their system rejected it. We tried another card and it worked. She was very helpful but it was not my first choice to use an alternative card. Ring needs to address this glitch in their system. Of note, my card of choice was valid in every way. All info was correct. I was well below my max spending. I use this card everyday, for everything.