Videodoorbell Pro not detecting on wifi


I installed my ring pro doorbell, but after a couple of days, throws an error no connection to wifi.

Checked all the basic stuff;

1)Light glows on the doorbell also it rings from outside but not ringing on chime.

2)That proves that there is power as it is hard wired

3)Once resetted, it does not detect the ring wifi device, there is no ring device on wifi, checked on multiple phones.

Only doubt goes on the wifi module being faulty on the door bell pro, but tried to explain this to customer service, given deaf ears.

Please advise any actions that i am missing.



Only things I can think of is does your WIFI router have it’s own firewall? If so it could be blocking it because it does not reconize it as a safe device or conection. If this is the case best bet is to look at your router manual to configure the firewall or your ISP.

Other is the WIFI signal from the router. If you live in a crowded area, and everyone has WIFI this can interfere with the signal, distance of router to device, recent update to the router (some update automaticly), etc can all play tricks on your contected devices.

Hopefully this helps.

1 Like

I just installed a Video Doorbell Pro and was extremely frustrated that the install wasn’t going easily. I couldn’t join a Ring wifi network, I reset the doorbell with the orange button, I reset my phone, reset my wifi, turned off my router, unplugged other Ring devices. I found on a site in the UK about an issue with wifi channels to make sure the Wifi Channel was between 1-10 not higher. Going into my Router Admin Settings, I found that my Wifi channel was automatically set to 6. I changed it to 5 just to see what would happen and instantly the Ring network appeared on my laptop and my iphone! That was it. From there, the installation went fine.

1 Like


I’ve got the same issue.
I just received my new Doorbell Pro 2 and I can’t connect it to my Wifi (2,4 and 5Gghz) network.
For testing I put my Doorbell far from 1 meter to my router but no Internet connection.
Wifi channels used are 11 (2,4Ghz) and 44 (5Ghz) .

Last update : I’ve changed my Wifi channel from 11 to 1 and it works perfectly now.

1 Like