Video Doorbell Pro Does not always Prebuffer Video Recordings

I just installed my Doorbell Pro this week and at first prebuffering seemed to work well consistently … i.e. recodings would be saved online begining a few seconds before motion was detected. However, now it seems like this is not always working. Is anyone else having this issue? Could it be firmware or termpaerature related? (it’s cold - below freezing where I am). Thanks!

1 Like

I live in Minneapolis (cold). I had the same problem with my Ring Pro, the pre-buffering became intermittant and eventually stopped altogether. I called Ring support and they remotely rebooted my device restoring the pre-buffering. I wonder how long it will work. Hope that works for you.


Thanks for this idea. I rebooted the doorbell myself via the electrical breaker yesterday (same as a remote reboot?) . So far it seems good/ better. Like you said we’ll see how long it lasts. What I did notice was if you have a few motion events close together the prebuffer is good for the first but less so for the others. Will keep you posted. Let me know if you find out anything else on your end. Cheers!

1 Like

I’m having this same issue. It worked fine at first install and now, if someone took a package from my porch, I’d get a video of them half-way down the driveway. I’m going to try resetting the power from the breaker and see what happens.

Yeah mine started acting up yet again a bit after the breaker reset. It’s inconsistent. I guess many will need to put in a support case before they take notice. I’ll do one soon and post any update. Let me know if you/anyone does the same…

1 Like

Where do we open a support ticket? Do you have to call? I just hit the breakers. I’ll report my findings.

They seem to have some support phone numbers:

• US: +1(800) 656-1918 (24/7)
• US: +1(888) 981-8993 (Español - 24/7)
• INTL: +1(310) 929-7085 (24/7)

Also I have seen en email address go through somewhere:

1 Like

My breaker reset did nothing. When I walk outside, this is where it starts recording. Guess I’ll be contacting support.

Hi again - I have been on the phone with them this morning.

They claim there is a compatibility issue with the snapshot feature (the one which take stills every x minutes) and the premotion “roll” (AKA buffer). Per their advice, I disabled the snapshots, but still having the issues. We even did a reset of the device. They are currently researching it some more and will call me back later. Will keep you informed… but for sure I think the more people report the issue, the more of a priority it would become to get a fix for this.

One observation since we have done many tests this AM is that the premotion seems to work when it’s the first event in a while (example first of the day) or just after a reset of the device. But it stops working for subsequent events (just my observations from today)…

PS - I am impressed by their tech service - someone has stayed on the line with me this whole time (1+ hrs of troubleshooting with their Level 1 then their Level 2 support…) which inlcuded an accidental disconnect and they called back…

1 Like

I’m experiencing your same issues. I have the snapshot feature turned off on my cameras because I heard from others that can cause an issue. I’ve reset devices and connection and sometimes would get success on the first try but never subsequent tries. What’s really odd is when I instaled the products a few weeks ago, they worked perfectly fine every time. I wonder what changed?

I have a feeling (personal) that this issue may have started with a firmware update they pushed down at some point. Mine too seemed to work ok when first installed but I started seeing the issues a bit later. Likely the default firmware was old and got updated to this new “buggy” one. They were probably trying to resolve some issue and unknowingly created another. Anyway I guess call them when you can at least so they have a few customers complaining about the same thing and maybe we’ll get a fixed firmware sooner (the agent seems to allud to them trying to develop so that both capture and premotion features will work)

My Pro has again lost the premotion/prebuffering. I called the support number and had them remotely reboot my device and it is working again, for now. I had them add another ticket encourage a better fix. I agree the more people that submit support tickets the better chance we will get a permenent fix.

1 Like

Hi All,

I got an email from their support team this morning - seems confirmed that it’s a known issue and they are looking into it:

"We’re sorry to hear that the first few seconds before your motions are not showing in your recordings, but rest assured that our team is looking into it and working to resolve it as soon as possible. In the meantime, if there’s anything else I can help with, please don’t hesitate to ask.

If you ever do need to reach back out or need assistance with anything, you can also contact us via phone, or via chat at

Thanks again for contacting Ring.

I too received an email, however a much different response.

Even though my original ticket said…

_ I’ve tried setting the sensitivity all the way up, increase the motion _
_ detection zone to full screen, nothing improves this. _

They replied…

Here are some possible steps for you to follow:
- Adjust motion sensitivity. If possible, you can set the slider to max.
- Adjust your motion zones, make sure that it will cover the area that you want the device to capture.

This tells me they didn’t really read my complaint. I guess we can all hope for the best.

yeah I have a feeling you need to get to their level 2 tech by calling the phone support line versus emailing/chatting etc… You need to get past their level 1 people who just know the basic troubleshooting. I spent about 20mins with level 1, rebooted my router with them before getting to level 2…

I was lucky that I had 1hr+ to kill on the phone with them as we did multiple tests showing them the issue (and i also authorized them to look at my recordings). I was able to prove to them that sometimes it worked and othertimes not… I opened my front door and waved at the cam. First time it caught me opening the door, vs subsequent times it did not…

You can also refer them to the case I have open with “Janette” from their Level 2 team in Arizona. I wish there was a ticket number, but they seem to track things only by email address…

I called again yesterday and had my Ring Pro rebooted. That worked for less than a day. I talked to support (Joe) in collaboration with the “advanced team” for an hour and twenty minutes going through several different tests and repeated device setups. After sending them pics of the device, the wiring into the device, and my mechanical door chime wiring they are sending me a replacement device. I’ll repost when I determine if the new units have the prebuffering problem solved.

They had me take the cover off and press ‘n’ hold the reset button for 20 seconds… then press it again. So far, it’s worked twice. I’m not holding my breath from a long term fix though.

I did that orange button reset as well during the troublshooting. It did works well twice… but the 3rd time for me went back to the cutting the start of the video.

It’s really odd to me that the offer different solutions to a known issue. I replied by email to Janette about this very fact (I guess she owns my issue so can reply) and it really looks like it’s a firmware fix which will solve it; that is whenever they finish developing/testing it and they push it out remotely.

Here is what she said:
“I completely understand why mixed information online could warrant some confusion. […] As always troubleshooting can take many turns and have a different path for resolutions based on the root cause of the issue. I assure you that the next step in getting this resolved for our team to continue with the investigation and move forward with an up to date firmware. Rest assured we are working diligently to resolve your concerns and you will receive an email once this issue is resolved. Per our policies and procedures, I am unable to answer on the thread directly but have forwarded this to our Social Media Team for further support. […]
Thank you!

She seems to be very much on the ball I think - we just need to give it time to get a peper fix. I am curious to see how the new unit will work out for f350bronco tho :slight_smile:

Me too. I haven’t had my 3rd motion sense. I will though when my wife comes home and we’ll see what happens.

So far I’ve had 6 successful recordings. If only this would remain, but judging from others results, I’m dubious.