Video doorbell mod 2 refuses to recognize charged battery

Video model 2 shows battery level at 3%. Inserted newly charged battery (shows only green light), doorbell flashes blue and then stops flashing…
Same result (batt level at 3%). Recharged original battery to get only green light (should be full charge). Replaced battery with now fully charged battery, same result???
Unit is not recognizing fully charged batteries.
Tried ‘setup’, to no avail.
What gives?

Hi @Raneel. Typically, the battery level will not update until the Doorbell button is pushed, or a motion event is detected. When this happens, the Doorbell communicates with the server and the proper battery percentage is displayed.

1 Like

I have had this same issue. Battery is fully charged, but when reinstalled, it is still showing low battery charge. I tried the suggestion of ringing the doorbell to reset and it didn’t work. Doorbell was just purchased in April. One would expect the battery life to last longer than a month and a half.

Hi @IREP-09. It sounds like there could be an issue with the battery. Ensure that when you’re charging the battery, you’re using the provided charging cable plugged into a standard power outlet. Charge the battery for about 8 hours before inserting it back into your Doorbell. Then reset the Doorbell by holding down the setup button for at least 20 seconds. After the reset is done, set the Doorbell back up in the Ring app using the steps under Set Up a Device. Test out a Live View or ring the Doorbell and check the battery percentage after to see if it’s reporting correctly.

If the battery is still showing a low charge, you may need to replace the battery. For that, please give our support team a call at one of the numbers available here so they can further assist. If you are outside of the US, please visit here to see how to contact support.