Video Doorbell 3 Plus Junk

I am having a recurring issue with my 3 Plus. After working for several days with a strong wifi signal, it just stops working and tells me “Activating Device” in the app. In this state, it is not recording or picking up motion or ringing as a doorbell. It is hardwired and I get my internal doorbell ring, but not from the hardware. It is connected to my 5 ghz wifi and has an IP address. It is sending and receiving packets fine and is online. The app shows it as online and connected. Device health checks out. If I go to, I can see events that are not on the app. After a few days, it just starts working again with no intervention. Then a few days later, it goes back to the activating device stage. I am on my second doorbell as support swapped out my initial one as bad hardware. The second one does the same thing. It is like it is going into a deep sleep state and takes several days to wake up. I am a network engineer and it doesn’t matter whether it is connected to 2.4ghz or 5ghz wifi. Same results. I have a Comcast XB7 gigabit gateway and consistently have a 1Gb/s connection or higher. No other devices on my wifi network have any issues. Support wants to blame my network, but I have been able to reproduce it by connecting the doorbell to a 4G wifi hotspot. My doorbell is literally 3 feet away from the router. This appears to be a hardware/software bug that they are refusing to address. I have asked that this issue be sent over to management and devolpment, but they don’t seem to want to escalate. I have been on the phone for over 8 hours with support with no success as to why this device stops and starts working so frequently. They are sending me a Chime Pro, but that is not going to fix this issue. I have checked all the settings on my network and router. I am not using a firewall or any security options. I see the Ring doorbell as connected and online within my router. I never see it disconnect, but the app apparently is having an issue. It shows it as online with a strong signal, yet it cannot connect or process events. I have tried on both Android and IOS, with the same lousy results. This is supposed to be a security device, yet I have no confidence that it would work if I needed it to. I had such high hopes for this device, and it has let me down. If support and management doesn’t contact me in the next few days, I am going to return it and use my Nest doorbell which has never let me down. I thought with the Amazon acquisition, that Ring finally had their act together. I am so disappointed in this product.

Sorry to hear about this experience @gvass75! I appreciate you covering all these steps and for your patience throughout the troubleshooting process. Our support teams are trained to explore various options and steps to reach your solution efficiently. As you seemed to have covered all the basic and advanced steps, in which the best next steps would likely be an advanced solution such as network configuration settings, or mobile device settings/ features, for example.

We take our neighbor’s feedback very seriously and have forwarded this to our teams for the most efficient handling. A team member should be reaching out to you soon!

Doorbell stills goes into “deep sleep” state periodically and stops working. Happened 3 days in a row for me. I have to remove the cover, remove the battery, and turn off power to the doorbell for it to come back. It is a real hassle to do this. Doorbell has a strong wifi signal and a reserved IP address with a long lease time. Firewall is turned off. Doorbell seems to go into this sleep state and doesn’t recover even though live view is enabled and recording frequency is set to update at the smallest interval to continue to keep it online. Wifi and Internet speed is rock solid and all other devices don’t have this issue. I also tried the Chime Pro as recommended by support. It does the same thing and puts itself to sleep. I have spent over 100 hours troubleshooting this product and support just can’t seem to get this to work properly and not put itself to sleep. This seems like an easy coding solution as I have provided sniffer traces showing the doorbell just stop responding to keepalive packets even though it is connected to my router and has a valid IP. Not sure what else to do as this is supposed to be a setup and forget device that should just work as long as there is power and a wifi signal. I am giving it a few more days as I wait for any response from support and the developers. App needs to have an option to restart the doorbell as removing the cover and battery and then killing power is not a viable option. The orange button does not suffice even if you hold it down for 30 seconds. Strongly considering returning it and going back to Nest as their product is rock solid.

Hi @gvass75 - mind if we take a look into you account? Let us know if we can use the same email address associated with your Community account to see if we can further help. Thank you :slight_smile:

Yes. I left it in a non working state and I am waiting on Nicole to provide me with details on returning it and issuing a refund as we had discussed previously. Like I said, I reverse engineered the product and provided the details to your developers on how to fix this defect several months ago, but it hasn’t been fixed. I was told that Ring would refund my money if you couldn’t fix the issue and I wasn’t satisfied. I am not interested in troubleshooting this further as I have given ample time for issues to be resolved. Please have Nicole call me to arrange return and refund on my Amazon purchase.

I am having the same exact issue. I however still have my old Ring 2 and I can put it online in the same exact place, front door, and it works flawlessly. One difference, I can’t connect at 5g anymore with the Ring 3 Plus. When I first installed the Ring 3 Plus it connected at 5g. After about 3 weeks it started sleeping. It refuses to connect at 5g anymore and I have to force it to connect at 2.4ghz. Even at 2.4g after a couple hours it goes to sleep and will not wake up. I’ve been trouble shooting for about a week and nothing seems to work. I have 7 Ring cameras and all work flawlessly. I also have Comcast 1g network. Most cameras show RSSI -50 or lower. The Ring 3 Plus shows -39.

Hi there, @Thump1! As you mentioned several other Ring devices working just fine at this location and on the network, this is certainly odd to hear. Using the 2.4 Ghz wifi frequency was a great call, as this connection can often be more dependable over long distances or through exterior walls compared to 5 Ghz. Try performing a reset on the Doorbell 3 by holding the setup button for 20 seconds. Once complete, reconnect the Doorbell and test to see if operation has improved.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.