Video battery not detecting battery

I recently bought a video security camera for my garden. I installed the wall mount etc, fully charged the battery, and hooked it up to my ring app and account. However, the app is constantly telling me it cannot show anything due to a low battery. This isn’t the case - the battery has been fully charged. I’ve tried it a few times now. The device health and power setting screens then show battery level as : add battery. So is it not detecting a battery?

To confuse things more, when I log into ring through safari, I can get the new camera to show a live view, but only through safari. I have tried resetting and installing the camera again, same issue. It connects, updates in the app for 15 mins, then same issue, can’t show any live view.

What’s the problem here, can anyone help? Dodgy battery? I have a basic plan to cover my doorbell for €39 a year, and the new security camera has apparently given me a 30 day trial of the protect plus plan. Could this be the issue?

Hi @user30117. You have tried the basic troubleshooting steps I would have recommended for your concern. The next best step would be to give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.