Unable to subscribe - Redirects to dashboard


I am unable to subscribe to Ring. I had a ring device for a couple of years that I was subscribed on, I then have a wonderful person come to the door and remove it. Once that happened I cancelled my plan and purchased a new device.

The new device has 1 day trial left and every time I try to setup a plan, it just redirects me to the dashboard page…

I have tried using the bot and chat system on the website that advises me to call the number, after 10 minutes on hold I thought I’d try here.

I am not sure if my old device’s subscription is interfering with getting a plan on the new one as when I choose “view plan details” it also redirects me to the dashboard…

Any help would be appreciated.

Hi @user20777. Did you remove the old Ring Doorbell from your account or cancel your previous plan at any point? Try using a different web browser or device to access your Ring Protect plan from Ring.com to see if the same thing happens. If this keeps happening and you’re unable to get signed up for a Ring Protect plan on Ring.com, please follow up with our support team at one of the numbers available here so they can further assist. If you are outside of the US, please visit here to see how to contact support.

Hi Caitlyn,

Thank you for replying. I really didn’t want to remove the old device from my dashboard just yet as I still may need to access a recording off it.

After removing the device I was able to setup a new subscription. Thank you for the assistance.

1 Like

@user20777 I’m glad that worked out. Let me know if you have any other questions. :slight_smile: