Unable to see video


My Ring peephole camera is stuck at “loading live view…”. When I try to view the video it is completely black. I have looked at all solutions proposed, and none seems to be working. Here’s what I have tried:

-Connected to a 2.4ghz network.

-Connected to guest network.

-Connectivity test seems to be good to go.

-Connectivity signal seems to be stable and strong, all green bar when connecting.

-Router is about 2-3 foot from the door.

Please assist, thank you.

Same issue, virtually the same setup

I have the same problem. I have two peephole cams and one works but the other does not. I bought a chime pro and I still cannot see any video. I’m so frustrated that I’m ready to return all of my ring products.

Same issue - anyone respond? Ring has zero support?

Hey neighbors! This is not a direct line to support but I’d be happy to offer a few suggestions and point you in the right direction. If you’re experiencing black videos in your Event History, I’d recommend checking out this Help Center Article here, which goes over various router settings that you may need to adjust to correct this error. You can also review our Community post regarding Live View here if your concern is just that the Live View is not loading.

If you’ve tried those suggestions and this concern persists, please give our support team a call at one of the numbers availablehere. They’ll be able to work directly with you to look at your device and help diagnose what’s causing the behavior you’re experiencing. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support.