Unable to Pair Schlage BE469ZP with Ring

I have been struggling with this for nearly a year.

Here are what I have tried.

  1. I tried connecting the lock with Ring using the default procedure in the app (tapping the BE469ZP option) but there was no “listening to device…” pop-out after I scanned the QR code. Instead, I got the attached screen with “Put the batteries in the lock”. However, the batteries are already in the lock.

  2. I tried connecting the lock manually (tapping the “ADD MANUALLY” option). It looked smooth at the beginning but I got a red light on the lock’s Z-wave chip and “Device Security Error” in the Ring app.

  3. I tried upgrading the Ring Alarm firmware and rebooting the Base station. The same results turned out in Step 1 or 2.

  4. I tried factory resetting the lock. The same results turned out in Step 1 or 2.

  5. I tried clearing the Z-wave chip on the lock following the steps in this thread: https://community.ring.com/t5/Ring-Alarm/Schlage-Lock-not-connecting-with-Ring-Alarm-hub/m-p/1245. The same results turned out in Step 1 or 2.

BTW, after each time I failed to pair the lock with Ring, I remove the lock from the app.

Any other suggestions?

Hi @yjjart. When you are trying to set up the lock to the Base Station, how far are the two from each other? Normally when you’re setting up a new device to your Ring Alarm system, you will want to make sure the device is as close as possible to the Base Station to establish a secure and stable connection. From there, you will then move it to the location that it is desired to be in. If the device is too far from the Base Station, say in another room or so, it could have problems connecting and therefore resulting in your getting an error message on the lock and having to remove it from the system and try again.

I see you’ve taken a lot of steps to try to get this to work for you, but it seems distance may still be something we need to fix first! If you cannot move the lock near the Base Station, I recommend to bring the Base Station near the lock! For this, just unplug the Base Station, rehook it up in an outlet as close as possible to the lock, and wait for the Base Station to come back online and look stable in the app as it was before you moved it. From there, try to same steps as you have to try to get it connected. To make things easier, you can also be on the phone with an agent from our alarm team while you’re doing this, as they can look into your account with you.

Ultimately though, if you still run into this concern of it getting an error message that it’s not added properly, this would be the best time to contact Schlage directly. You can inform them that you’ve exhausted all troubleshooting steps with us, and they should be able to help you get it sorted out on their end, or get a new device from them as well if that one is deemed to not work.

Hi Chelsea. Thank you for getting back to me promptly. I tried to move the Base Station to within 3 feet from the lock. It still did not allow me to pair the lock to my system. I am in contact with the Schlage now.

1 Like

@yjjart Thanks for getting back to me and letting me know! Please let me know what Schlage says, as this may also help other neighbors .:slight_smile:


I had the same problem. It seems that a factory reset of the Schlage lock DOES NOT reset Z-wave. This procedure worked for me:

  1. Open the Ring app

  2. On the upper left hand side: tap the three lines (hamburger menu)

  3. Tap “Devices”

  4. Scroll to “Security” and tab “Alarm Base Station”

  5. Tap “Base Station”

  6. Tap the “gear” in the upper-right

  7. Scroll to “Tools” and table “Advanced Options”

  8. Under “Protocol Adapters” tap “Z-Wave”

  9. Tap “Remove Z-Wave Device”

  10. At the bottom of the page, tap “REMOVE”

  11. Now go to your Schlage lock and enter the programming code, tap “Schlage” on the keypage + the 6-digit programming code.

  12. The lock will flash the check-mark, then press “0” on the keypad. This should successfully erase the z-wave programming in the lock.

  13. Now try the pairing sequence again in the Ring app.

This made it possible for my lock to connect. However, I still have issues which might be related to old firmware on the Schlage lock (version 5.6). Make sure you have firmware 5.7+.

Good luck.



Thank you so much for this !!! My Schlage lock was associated to my prior alarm company and I took out their equipment not knowing a factory reset on my door lock would not reset Z-wave. I was starting to think I’d have to buy another lock when I found your instructions. It worked and I was able to add my lock to my Ring system.

1 Like

Thanks for the info. It helped me as well and saved me from dealing with tech support. Not sure where I went wrong on the setup but by removing it solved the issue.

Thanks! This worked like a charm!

This was a GREAT step by step method to remove device and reinstall!!! I will use it again for sure.