Unable to charge - Video Doorbell v2

Hi,

We recently changed internet provider and had a bit of a nightmare which resulted in being without a connection for over 6 weeks.
Anyway, now up and running and connected our hardwired Doorbell to the new WiFi without problems. But our battery one would not go into set-up mode (white light). Thought maybe the battery needed charge so plugged in, but the blue ring flashes 15 times and then goes out. No sign of it continuing to charge.
Can anyone tell me if the battery is just so low that it will take some time plugged in to start to register a charge or if there is some other problem?
Many thanks.

Have you tried other USB chargers and/or cables?
If that doesn’t get your battery to charge it could be that the battery is “worn out” and needs replacing.

Tried other cables including the original one. Only have one charger although it charges my phone ok.
The doorbell is only around 4 months old.

Hi @user8670. Try performing a reset on your Doorbell. You can do this by pressing and holding the setup button for 20 seconds, then releasing. After that, you’ll be able to reconnect the Doorbell to WiFi. Let me know if this helps!