Unable to access modes in app

I am unable to access modes in the app. I have tried everything, including using a different device, and uninstalling and reinstalling the app. When I click on modes in the app, I get an error that states “Our system is experiencing a delay. Our system can’t process your information right now. Please try again.” This has been happening for the past several months.

I am also having an issue when I click on live video, half of the time I get an error message that says “Live view is not available in this mode.” I have to exit the app and try again to view live video.

Has anyone experienced these issues? Anyone have tips to resolve. I’ve tried everything I know how to do on my own.

1 Like

Hi @Ellie85. Make sure you have a stable connection to the internet via wifi or cellular data, and that bluetooth and any VPNs are disabled. Also, try accessing the Modes settings from a different smart phone or tablet if you have the ability to do so. If it’s still not working, would you mind sharing a screenshot of the error message you’re receiving when you try to access the Modes feature in the Ring App?

Wifi strength is great. Tried on multiple devices but receive this same error message.

1 Like

I also frequently encounter this error.

@Ellie85 Thanks for sharing those screenshots and trying on multiple devices. Since this error is still occurring, would you mind reaching out to our support team for this? You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I am receiving the same error (“our system is experiencing a delay”) on both a Samsung Galaxy S20 and S21 both running Android 11. App version is 3.38.1, which is latest. The Mode setting feature does not work at all on Android devices. I have tried to uninstall, Clear all data, reinstall, etc. To no avail. Please fix this problem. it’s been an issue for at least 6 months if not more.

I have reached out to support, however they offered no option other than to tell me the iOS app works better. Yippee, especially considering Ring is owned by Amazon and Amazon makes Echo and Fire devices all using Android.

Did you ever find a fix for this issue?

Hi @Scott_H. In addition to the above mentioned suggestions, I recommended checking your phone for apps that may be conflicting with the Ring app. You can find a list of some of these apps here. I hope this helps.

This is still an issue as Mode Settings does not work. All recommendations have been checked and tried. The 1st time after installing Ring on multiple devices, and clicking on Mode Settings, an error message reads - “it is not possible to save, please try again later”. If I then exit the screen, it says “are you sure? If you leave now we will not enable mode settings for your cameras”. Following all that, going back into Mode Settings results in the error noted in this threads original post.

Hi @krarms. If the suggestions do not seem to be fixing this for you, it would be best to reach out to our support team. Feel free to let the Community know how they were able to help.