Times in Camera Event History stuck on GMT (Android)

As of recently, I am experiencing issues with my cameras in the Android App. I have 4 cameras. One Doorbell and 3 Indoor Cams. When I launch any of these cameras in the Android App, the time in the timeline for camera events displays correctly (I am CST). However, when I go a step further in the camera settings and click on Event History, all of the camera events display in GMT. The timezone is still correct but it displays in GMT. It never did this before. Once I play one of the events, the time displayed on the video is CST again. This is very frustrating though because as I scroll through events, I have to subtract 6 hours to try and figure out what time the event was recorded.

I have tried many of the common fixes suggested for time issues on the app. I made sure that my phone is set to Automatic Timezone, I verified that the address entered on my account is correct and confirmed it. I tried clearing the cache and when that didn’t help, I uninstalled and reinstalled the app. I have also confirmed that this issue is exclusive to my Android Phone. When I launch the app and same account on my Ipad the issue is non-existent. I am not sure if this started with a recent update or not. Any help or suggestions would be appreciated.

1 Like

Thank you for covering all of these steps and sharing this feedback. As this sound isolated to the mobile device, please also ensure there is not a VPN enabled. When using an android device and Ring, please check for any android apps that conflict with the Ring app.

If this concern persists, our support team can certainly take an in-depth look at this, to investigate or resolve further. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

Mine is stuck in GMT. Even when making a schedule for any of my devices. And I don’t have any of the conflicting apps.

I have the same problem and it doesn’t allow be to set schedules because it cannot recognize timezones

No, I don’t have a VPN. I worked with tech support for extended time and following is my observation:

  1. The tech support asked me to create a new location using same address
  2. Asked me to move all by cameras to the newly created location.
  3. After moving all my cameras, the app allowed me to define motion schedules and it should timezones correctly.
  4. I went ahead and re-registered my security system to new location of same address and the issue popped up again. I cannot set motion schedules, it says disabled because it cannot find time zone of my address and all the videos shows GMT.