Thumbnails on Dashboard won't update


I’ve seen this topic floatded around a lot but I don’t see any solutions suggested that anyone said worked.

Everytime I charge my VIdeo Doorbell (2020), my snapshot feature gets screwed up. The thumbnail on the dashboard no longer updates (just shows a static image of a picture of a ring doorbell), and my motion zones can’t be adjusted because in that setting it just hangs at “snapshot being updated”, and never does.

This is the third time I’ve charged my doorbell since I got it, and it has happened everytime, and the only solution was to do a full factory reset on my doorbell. There has to be a better way. I cannot factory reset my doorbell everytime I charge it. Nor can I afford to sepnd another $50 to get the solar bezel so charging is never needed.

As I said, I see this topic a lot on the community but I don’t see in any of the threads that an effective solution was given, that a user confirmed worked. Maybe these conversations went offline one on one. Can someone please let me know if there was a way to solve this issue.


Hi @pezzman77. Thanks for letting us know what you’ve tried before and how that has worked. After charging the battery, have you tried toggling the Snapshot Capture off and then back on to see if that corrects this error that you’re receiving? If that doesn’t work and it still requires a reset, then I’d suggest giving our support team a call so they can take a closer look at this by pulling up your account. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

I am having the exact same issue w/ my Doorbell 2 with thumbnail on dashboard not updating. My front “doorbell 2” updates as it should. My back doorbell does not. It shows more or less a “static” picture of last motion or a recording. The date is also located lower left of snapshot pic instead of the updated time. The date is wrong as well, by 4-days I have tried everything, re-install app, hard re-set on doorbell, re-load internet and so forth. The RSSI value is -49. This same camera also has a very hard time getting “live views” and picking up motions at times. I can stand right in front of camera and it will not go off. Yet other times it works? Very frustrating. I could use some help here if anybody has had same issue and resolved it, or Customer supprot from Ring. Thanks much and stay well