This is a horrible product

It connects to the network but then say it can’t connect to the internet so you have to start over. I have reset it several times. My network is fine, the other chime pro that I have, that is within sight of the WiFi router, works fine. I have tried to set it up closer to the router, like 5ft away and it sets up. Move it 25ft away and it goes bust. Are there advanced setting or set up that can be done, by someone who is a software engineer, without having to go through these mind numbing prompts?


I’m having the same problem. I bought another chime pro after the first started having connection problems after a year of working fine. The 2nd one says it connected to my WiFi but can’t connect to the internet. Tried multiple times to set up and it’s the same result. Nothing is wrong with my internet. The chime is 3 feet from my router. What’s going on with this piece of crap?!?!?!?!


Sorry to hear about this @Sonarman and @SgtSak! It sounds like in both instances, your Chime Pros are close to the router and not separated by interfering objects. These should certainly be connecting and operated as intended. If possible, can you try enabling a guest network on your router to see if the Chime Pro will fully connect to that?

1 Like

Sounds very similar to the problem I was having trying to setup the Doorbell II this weekend. Not sure of what caused the problem – seems to be an issue with how the setup software works with the router to obtain a DHCP IP address. After having tried the installation better that 20 times by myself and working with the Ring tech support, problem was unresolved.

Getting ready to give up, I discovered that my iPhone XR (the one I was using to setup the Ring II) was also having issues connecting to the internet – a problem I had not seen before going through the Ring setup. I solved the problem on my iPhone by manually reserving (assigning) an IP number to the phone through my router. (I am an Xfinity customer and am using their latest router/gateway (the TG3482G by ARRIS Group)). Restarting my phone using the reserved IP solved the problem.

As a last resort, I tried the same thing with the Ring II – that is I reserved an IP number for it in the gateway using its MAC address. I restarted the Ring II setup, and this time it completed successfully without a hitch. It is now up and working as advertised.

Bottom line is that there appears to be a bug in the setup firmware version which came with my Ring II. As the setup procedure is similar/identical for other products, it is likely affect other products using the same version. It may be specific to the brand/type/version of the WiFi gateway being used. It may also be (and probably is) specific to the version of the firmware installed in the purchased product when it was built.

I agree 100%. I purchased my Chime Pro less than a year ago. Today, after a short power outage, it finally died, completely. I ended up hooking everything up to a wifi extender (not related to Ring) I purchased online. Now it works wonderfully.

Over the last 6 months, I have spoken to customer service reps who didn’t seem to understand the Chime Pro would _ not _ turn on. It would take at least an hour before it would finally connect. It is definitely frustrating, especially for the cost of the products.