The Ring App has a Temporary Connection Issue - Still!

I continue to get “The Ring App has a Temporary Connection Issue. We hope to resolve this issue soon. Please try again later” error message when I open the app, along with “We couldn’t load your Ring Dashboard” error displayed at the top of the home screen. But, when I go into my Front Door camera everything seems to be working fine, showing the Live view and all. Would just like for the annoying error messages to go away. I’ve tried the reinstall option. This has been going on for awhile now and many seem to experience the same thing. When can we expect this to be fixed?

Hi @NVricochet3006. Could you take a screenshot of what your app looks like when you have this error message pop up? When you go into the app, are you on wifi or data? When you close out of the app and then reload it back up, do you have the same error message? Does this look different when on mobile data only instead of wifi? I notice this pop up sometimes (if we are seeing the same one which I wanted to verify with a screenshot) when I load my app for the first time in awhile, while connected to wifi on my phone or in a poor signal area for data, because the app is still loading and thinks I have a poor connection, but it’s just the app still loading and making sure my connection is good, even though it’s slow.

Pics attached. WiFi or Data, same results. Closed and reopened, same results. I’ve been seeing this for awhile (month? maybe) and just today tried to resolve by uninstalling the app, restart the iPhone, then reinstall. Same results. Other than the error messages, the Ring DB device seems to operate fine. Also, my wife’s iPhone Ring app says the same. Would just like to rid the error msgs.

I am also having this same issue and it seems to have started when the app was last updated. I would really like the use of the app back to normal without these errors. I have attached the screenshots that I took. Please help!

I am having the same issue. Nothing has changed on my end, and the app just quit working. I had this happen a few months ago and spent hours and hours on the phone with Ring support and they could not solve the issue. It started working again the next day on its own. They were supposed to call me back with second-level support and never did. This only happens on wifi, three different iOS products. Phones and iPads.

also, if I log out of the app and try to log back in on Wi-Fi it says invalid credentials.

Yes I have the same problem as well. I can login into the website fine, but the mobile app will not let me login with same password. I am getting"invalid credentials" also after I reinstalled the mobile app. I tried logging in with cellular only and WiFi no luck.

The app went back to working for only ONE day then back to the Connection Issue error. It states “we hope to resolve this issue soon”…This has been like this for over a week now. I would really like to use the app at full function. Please update this soon. As I stated before, the issues started when the app last updated. Apparently there is a bug within the update.

I noticed now that my app is no longer displaying this issue. I have done nothing more on my end so my guess is the app updated itself. Pretty sure thats the case since it now shows the ‘Modes’ feature on the home screen that I didn’t have previoulsy. I unfortunatly didn’t take note of which version it was when I first submitted this, but my current app version is 5.26.1 and the latest available is 5.27.0 which I’m hesitant to install.

1 Like

Quick update. Everything is still good, and the app had updated itself on its own and is now at version 5.27.1 (the version is displayed at the bottom of the drop down Menu, under Help)

1 Like

Just noticed that I’m also getting this error message “The RIng App has a Temporary Connection Issue” now. Also only noticed I didn’t get any notifications today either. And I can’t connect a live view on my iPhone or iPad. With WiFi or cellular.

Software version number is 5.27.1

is it a case of just waiting or is there something else I need to do now?

Hey neighbors! Thank you so much for reporting back to me and providing me that information. I do also greatly appreciate those screenshots, as it does clear up what message you are running into. Rest assured, our team is currently looking into this, and we appreciate your feedback on the app as it is vital to this process.

In the event that you are unable to use the Ring app and you are in need of immediate assistance, please do not hesitate to give our support team a call directly at one of the numbers available here. As we are a neighbor to neighbor forum, you will need to give our team a call for this direct support. We appreciate your patience while we are looking into this.

When will this “temporary connection issue” be resolved so the Dashboard can be used?

I’ve got the same issue; both my wife and my phone. Same attempt to fix: deleted apps, restarted phones, reinstalled. Nothing works. I’d like a fix to this quickly or these cameras will be headed back to Best Buy.

Good luck with that! Had issues then no issues for a month and now back to having dashboard issues not loading. This is getting ridiculous!! I just want my app to work the way it’s supposed to!! About to take these down and order ones from Blink as I’m not having any issues with those on my other home!

I get the same message for no apparent reason, when I tap try again it connects right away.

I have good wifi and door press button works well otherwise.

Why does this still happen?