The pages for 'My Plan' and 'Account' don't load in desktop browsers.

The pages for ‘MyPlan’ and ‘Account’ don’t load in either Firefox or Chrome
browsers.

When I first installed and configured my Ring device, I purchased the
Basic Protection Plan using a desktop browser.

Now…

A blank page [https://app.ring.com/login?at=random_characters] with a ‘spinner’ below a
ring logo appears - and never loads any content.

Messages appear in the lower margin:
“processing request”

then:
“waiting for app.ring.com

then:
“establishing secure connection”

then:
“processing request”

The pages never successfully load.

I can view and manage [star and/or delete] video in a browser, but have
been unable to access the pages for ‘My Plans’ or ‘Account’ from a browser
for a few weeks.

I cleared cache, cookies, etc. and restarted computer and also tried on
another computer. Still no joy - those pages simply will not load for me.

@MobileMike, You’ve had problems before with these sites and such. There has to be something on your end that’s causing it. I can go to all of them and in the control panel in the Ring app as well. Are you using a VPN or any kind of antivirus or anything like that? If you search, no one else is having these issues. If it was you know there would be many posts here.
I wish I could sit down with you and figure it out. There has to be something…

Here’s something to try if you use Firefox.
https://support.mozilla.org/en-US/kb/websites-show-spinning-wheel-never-finish-load

@Eagle328

Thanks for the suggestion - unfortunately, none of Mozilla’s potential “fixes” worked for me - and I’m not sure what might work in Chrome.

I just wish Ring support would even undertake any serious effort to determine if the problem could be with their servers.

I sent them a screenshot - and they offer the usual suggestions to clear cache & cookies & reboot.

Beyond that, they want to know what the MAC adresses are for all my devices, and invite me to call [presumably to offer the suggestions I’ve reviewed in their troubleshooting guides, such as the security settings in my router[s] should be set lower, etc.].

@MobileMike
They may be correct if you settings are set to high.
I’ve been here a few months and I subscribed to every thread. I don’t see many having the same issues that you are. Like right now the biggest issue seems to be the solar panels and charging. Last month is was extreme increase in doorbell false notifications. If you ever get it to work, please post back.

I tried to access My Plan and my Account on the website again …

Finally tonight - the pages loaded.

The URL[s] in the address bar tonight were:

https://account.ring.com/account/app/login?state=landing-plans
and
https://account.ring.com/account/app/login?state=landing-account

which are different URL[s] than when I first inquired about this issue:

app.ring.com/login?at=random_characters state=landing-plan s etc…

So … the website issue seems to be finally resolved.