*TechIssue, Help Please* Ring Alarm Basestation, Bluetooth, Locked Iphone txt alerts.


I was wondering if this issue was discovered by the Ring team or other users as well.

I just installed the Ring alarm kit ( I got a 10 piece kit) and I noticed that after I installed the system, that I was no longer hearing my txt tones while my iphone is locked (in my pocket, laying on the desk with screen off).

Naturally, this disturbed me quite a bit since I missed quite a few txts from family and friends over the last day. I have narrowed the problem down to the Ring Alarm system and I was wondering if anyone can help please.

Here is how things work:

With the Ring app installed and logged in to my account:

-If I have bluetooth “ON” on my iphone (but no devices are connected to it). I will NOT get sounds for txt messages while my phone is in a locked state.

-If I turn bluetooth to “OFF”; This fixes the problem and I then start to receive the sounds for txt messages while my phone is in a locked state.

I noticed that when I set up the alarm base station, it initially used Bluetooth to connect to my phone, so I suspect there is some interaction there, yet is not shown on the phone.

How do I know definitively that it has something to do with my Ring alarm system?

I DO get incoming txt sounds when my iphone is locked when:

  • The Ring app installed, logged into my ring account, and Bluetooth is “OFF”

  • The Ring app installed, NOT logged into my ring account, and Bluetooth is “ON”

  • The Ring app is NOT installed on my phone (this would make ring pointless though)

I *DO NOT* get incoming txt sounds when:

  • Bluetooth is “ON” and logged into my ring account.

From those tests, I can speculate that there is some bluetooth interaction when the Ring app is logged into my account, probably related to the base station?

Any help on this matter is greatly appreciated.

An annoying workaround is just to keep bluetooth “OFF” at home… then whenever you get in or out of your car you have to turn it “ON” and remember to turn it “OFF” when you get home. This of course is a very annoying thing to remember and do every single time you leave/enter your home.

I hope there is a quick fix for this.

Thanks for your time!

I greatly appreciate you taking the time to share your experience in detail with us, @ChuChuTrain! This should not occur, and is certainly an unusual behavior to hear of. Of course, you’ve found that disabling bluetooth results in the operation you expect with your mobile device. Great work isolating these variables.

I’ve shared this with our team for further investigation. For now, I recommend disabling bluetooth when you can. Removing and reinstalling the app on your mobile device might also help to improve operation. Although bluetooth is not related to network settings, if messaging alerts are not working as intended, refreshing your mobile network or even checking for any other unique or conflicting apps, can help. Feel free to keep us updated with any observations, as well as reach out to our support team if you’d like to troubleshoot this more in-depth with us.

1 Like

Thank you Marley!

I believe after further investigation that it is probably an issue with my phone / carrier MORE than an issue with the Ring product itself.

After hours and hours of troubleshooting, finally (with the help of the Ring chat representative, who was awesome btw) tried unregistering the base station and installing everything again.

The problem THEN persisted even after removing the base station, AND uninstalling the app from the phone.

I then surmised this is a problem with the phone carrier. For reference. I have Verizon mobile service. At my home I only get 1 bar of cell coverage, and use Wi-fi calling.

This is definitely a weird interaction.

For those who encounter this issue in the future, this may be a hardware issue. It seemed to have just coincidentally popped up and gotten worse since I installed the Ring system and initialized it on my phone.

I will be sending in / replacing my phone and seeing if this problem persists.

Hope this helps everyone.